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Getting Started1

Welcome to Easy Grade Pro from Orbis Software. With Easy Grade Pro you can create an electronic grade-

book which, like a paper gradebook, can be used to store student information for all of your classes and 

subjects. Better than a paper gradebook, an Easy Grade Pro gradebook provides an abundance of tools to 

save you time, provides you with a wealth of information, and allows you to generate professional paper 

and internet reports.

System Requirements
Easy Grade Pro is shipped as a MAC-only, WIN-only or a MAC/WIN cross-platform product. See the 

License label for specific information about the platforms included on the CD with this package.  

Requirements:
Macintosh: OS 10.2 or higher

Windows: 2000, XP or higher

Memory:  128 MB or higher

Hard drive space: 10 MB for installation and data files

Monitor: 800 x 600 or higher resolution with thousands of colors

CD-ROM drive: for installation only

Installing Easy Grade Pro
Important note: be sure to log into the computer as the computer’s Administrator before installing. Otherwise, 

the computer may block the Easy Grade Pro installer or block the registration process.

For Macintosh:
1  Insert the installation CD. 

2  Double-click the icon of the CD. In the window that appears, double-click the Easy Grade Pro 4.0 In-

•

•

•

•

•

•
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staller icon and follow the steps. Eject and store the disk. 

3  Start Easy Grade Pro by double-clicking the Easy Grade Pro 4.0 icon in the Easy Grade Pro folder in the 

Applications folder.

 
For Windows:
1  Insert the installation CD and follow the instructions that appear automatically. If nothing appears, 

choose Run from the Start menu, type D:\setup.exe and press enter. Use the drive letter for your CD-ROM 

drive in place of D. Eject and store the disk. 

2  Start Easy Grade Pro by clicking on Start in the corner of the screen, choosing All Programs, and then 

choosing Easy Grade Pro. 

FAQ: Can Easy Grade Pro be networked?
Because servers are generally slower and less reliable than the hard drives attached directly to computers, we recom-
mend that you install Easy Grade Pro directly to each computer and not to a server.  

Easy Grade Pro for Macintosh can be installed to a server using the standard installation instructions. Easy Grade Pro 
for Windows can also be installed to a server but you will need to copy the ProductID key (at HKEY_LOCAL_MA-
CHINE, SOFTWARE \Microsoft\Windows \CurrentVersion\Uninstall\Easy Grade Pro) to each workstation before 
the program can be used. Otherwise, Easy Grade Pro will display an error message that it has not been properly 
installed.

Registering Easy Grade Pro
The first time you use Easy Grade Pro, a registration window will automatically appear. Carefully type the 

registration (license) number found on the License label. If you are upgrading from an older version, use 

your original license number. Be sure to include the dashes. Click OK. Then type the registration name 

(school name for a site license or teacher name for a single-user license) and click OK. Be careful when 

entering the registration name because it will appear near the top of all reports. 

Be sure to complete and return the product registration card to Orbis Software.
FAQ: Why am I getting an error message when I try to register Easy Grade Pro?
If you are getting an error message after you type in the number and name, it is most likely due to a permissions 
problem.Your computer may be blocking Easy Grade Pro’s attempt to save this information because your login ac-
count doesn’t have a high enough permissions level. The solution is to log in to the computer using the computer’s 
administrators account just long enough to enter the number and name.

Updating an older version of Easy Grade Pro
If you have an older version of Easy Grade Pro on your computer, it is recommended that you first install 

the new version of Easy Grade Pro following the instructions for installing and registering Easy Grade Pro 

in the prior sections. 

Deleting the older version of Easy Grade Pro:
On Windows, you do not need to uninstall the older version. The Easy Grade Pro 4.0 installer will replace 
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the older version of Easy Grade Pro if it is its normal location at C:\Program Files\Orbis Software\Easy 

Grade Pro.

On Macintosh, the Easy Grade Pro 4.0 installer will not replace the older version. It is recommended that 

you find the older version and drag it to the Trash can and empty the trash. Warning: do not trash any 

gradebooks that you’d like to continue using with the new version.

Converting older gradebooks to V4.0:
Easy Grade Pro 4.0 can open all gradebooks created with older versions of Easy Grade Pro beginning with 

version 2.0. Here’s how:

1 Start up Easy Grade Pro 4.0.

2 If a gradebook opens, choose Close from the File menu.

3 Choose Open from the File menu.

4 In the window that opens, navigate to the older gradebook, select it and click the Open button.

Easy Grade Pro will inform you that the gradebook is from an older version and ask if it should be con-

verted. If you click Yes, Easy Grade Pro will make a copy of the gradebook and then convert the copy. The 

original gradebook will not be affected.

Learning Easy Grade Pro
Easy Grade Pro 4.0 offers many tools to help you learn how to use it.  These tools include:

Easy Grade Pro User Manual (pdf) 

Easy Grade Pro Help

Easy Grade Pro Online

Tool Tags (Macintosh) and Tool Tips (Windows)

All of these items can be accessed from the Easy Grade Pro Help menu.

�������������������
���������������������
���������������������

���������������������

����

The most thorough source of information about Easy Grade Pro is this Easy Grade Pro User Manual. It is 

designed to teach you how to use Easy Grade Pro. It begins with a Tutorial  and then explains step-by-step 

how to start your own gradebook, add classes, set options, add students and so on. The manual comes as 

an electronic pdf file. PDF, or portable document format, is a standard format for sharing readable docu-

•

•

•

•
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ments on computers. If your computer does not have the ability to open pdf files, free Reader software can 

be downloaded from www.adobe.com.  With this program, you can view the manual onscreen. You can 

also print some or all of the pages.

To view the Easy Grade Pro User Manual:
Start Easy Grade Pro. From the Help menu, choose Easy Grade Pro Manual. 

Alternate method: With Windows press on Start, choose All Programs -> Easy Grade Pro -> EGP User 

Manual. With Macintosh, the manual can be found in the Easy Grade Pro folder in the Applications 

folder.

The quickest way to get an answer to a question while using Easy Grade Pro is through Easy Grade Pro’s 

in-context Help. It provides information about the part of the program you are currently using so that you 

don’t have to spend a lot of time searching for what you need.

To view Help:
Choose Easy Grade Pro Help from the Help menu or click on the Help tool    found on the Tool bar. 

For the most current information about Easy Grade Pro, technical support information, update informa-

tion, or plug-in files with educational standards from different states, visit the Easy Grade Pro website.

To view the Easy Grade Pro website:
Choose Easy Grade Pro Online from the Help menu

Alternate method: browse to www.easygradepro.com.

If you are unsure of the function of any tool on the tool bar, simply point your mouse to the tool. A small 

box, know as a tool tag (Macintosh) or tool tip (Windows) will appear below the tool with the name of the 

tool. 

To turn on/off tool tips or tool tags:
Show Tool Tags (Tips) from the Help menu.

FAQ: What is the best way to learn the basics of Easy Grade Pro in the shortest amount of time?
If you are new to Easy Grade Pro, we enthusiastically recommend that you take a tour of Easy Grade Pro by going 
through the Tutorial found both in the user manual (starting on the next page) and the in-context Help. The time 
spent taking this tour will be time that you save later. It will also help you get started right! 

  

•

•

•

•



Tutorial: 
Four Short Lessons2

The lessons in this chapter will introduce you to the structure, tools and options found in Easy Grade Pro. 

The time spent here will almost certainly save you as much and more time later. The word to remember is 

explore; these lessons are meant to be springboards for your own exploration of Easy Grade Pro.

Lesson 1: Moving around in a Gradebook
1  Open the gradebook named Demo Gradebook. To do this on a Macintosh computer, double-click on 

the icon titled Demo Gradebook found inside the Easy Grade Pro Folder. On a Windows computer, click 

on Start in the corner of your screen, point to Programs, point to Easy Grade Pro and click Demo Grade-

book.

You should be viewing the gradebook of a fictitious sixth grade teacher, Ms. Demo, who teaches reading, 

math, language arts and science. She also teaches science to the students in the other sixth grade class. The 

other sixth grade teacher teaches Social Studies to both groups. Ms. Demo is currently in the second quar-

ter of the school year and you are viewing the score chart for the class Quarter 2: Reading. Notice the name 
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of this class on the tool bar.

The Class menu on the tool bar indicates that the class being viewed is Quarter 2: Reading. This menu can be used to switch to any 
class in any term of a gradebook.

2  Press on the Class menu on the tool bar to switch to Quarter 2: Math. Notice that Ms. Demo’s math class 

has most of the same students as her reading class but the assignments are different.

3  Use the Class menu to move to Quarter 2:Science-1 and then to Quarter 2:Science-2. Recall that Ms. 

Demo teaches science to both sixth grade classes. The science classes have the same assignments but differ-

ent students. To save time, Ms. Demo enters assignments into just one science class and then copies them 

to the other class. You’ll have a chance to do this in Lesson 2.

4  Move to the Social Studies class to view a class imported from the other sixth grade teacher’s gradebook. 

Notice that the students are the same but other items are different because this class was created by the 

other sixth grade teacher. Although Ms. Demo does not teach this class, she wants to keep track of her 

students’ performance in all classes and wants to include their Social Studies grades in the progress reports 

sent to parents and posted on her website. So, periodically, she imports the entire Social Studies class from 

her associate’s Easy Grade Pro gradebook using a floppy disk or her school’s network. 

5  Switch back to Quarter 2: Reading. Now, click on the Attend. tab above the Class menu to switch to the 

attendance chart. Make sure that you are viewing Quarter 2: Reading. Notice that the new chart displays 

dates and attendance marks. Ms. Demo takes attendance in just one class, Reading, because it is the first 

class of her day. She could, if she wanted to, take attendance in any or all classes.

6  A class actually has six different charts: score, attendance, seating, student, assignment and standard. 

Although Ms. Demo spends most of her time using the Score chart, she does use the others on occasion. 

Use the tabs above the Class menu to switch to each of the charts. In the student and assignment charts, be 

sure to use the scroll bars so that you can view all the different columns.

7  Each class in a gradebook can have its own students, assignments and configuration of the charts. Before 

moving on to Lesson 2, take a few moments to use the Class menu, the Prior Class  C  and Next Class 

C   tools, and chart tabs to examine the rest of Ms. Demo’s gradebook. Remember, explore!

Lesson 2: Adding Assignments and Scores
The most time consuming task in the grading process is that of adding assignments and scores. Easy Grade 

Pro provides many tools to make this task easy and fast. In this lesson, you’ll be introduced to some of 

these tools. To begin this lesson, the Demo Gradebook must be open and the score chart must be visible.

1  Using the Class menu, move to Quarter 2: Science-1. You’ll know that you are in this class when its title 

is visible on the tool bar. Be sure you are viewing the score chart. If necessary, click the Score tab or choose 

Score from the Chart menu.

2  To prepare for the entering of scores, click the small triangle below-left of the first tab so that the triangle 

points downwards. The triangle (circled below) shows and hides a row of grades and special scores.
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Click on the triangle (circled above) to show the row of grades and special scores below the tools.

3  Click the Add Assignment button visible after the last assignment or choose Add Assignment from the 

Tool menu. After clicking, the Records window will open to an empty assignment record.

The Records window is used to add assignments, students and classes to a gradebook.

4  In the Name field, type Star Lab.

5  Press tab to move to the Max. Score field. Type 25. 

6  Press tab to move to the Points field. Type 100. For a detailed explanation of maximum score and points, 

see FAQ: What are maximum score and points? How should I set them? on page 44.

7  Set the due date of the assignment by clicking on the calendar. The date is used by Easy Grade Pro when 

sorting, using filters to show or hide certain assignments and when producing graphs.

8  Press on the Category menu and select Classwork. The category is used when sorting assignments, in 

filters, graphs, summaries, reports and in grading if you have category weighting turned on. You can view, 

edit and create score categories in the Class Options window but you’ll see this later.

9  Click the Done button. You should be viewing the score chart again. The first score cell under the new 

assignment’s title should have the flashing cursor in it. If not, click on the first empty box under the Star 

Lab assignment. 

10  Now it’s time to enter scores. Just to make things interesting, you’ll enter scores in several different 

ways. Follow the directions below to enter the first four scores. If you make a mistake, simply click on the 

score cell with the error and try again.

Student #1: Type the number 25 and press enter.

Student #2: Click on the B grade on the tool bar. Do not press the enter key because the next cell is auto-

matically selected after clicking. You can set up the grades that appear on the tool bar. In fact, you can have 

a different set of grades for each student and for each category.
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Student #3: Press the letter m. This enters a score of mi for missing. You can customize up to thirty special 

scores and give them any meaning you wish. Notice that the score turns red. Ms. Demo has set things up 

so that all failing scores are displayed in red.

Student #4: Type the number 25. Do not press enter. Now click the Fill Down tool  F   on the tool bar. 

Notice that 25 is repeated all the way down.

11  Click the Undo tool    on the tool bar or choose Undo from the Edit menu to prepare for the next 

step. Notice that the score of 25 is removed from the students. Undo is nearly always available to reverse 

the last action.

12  Select the seven blank score cells by pressing on the first and dragging to the last. Release the mouse. 

The seven score cells should be highlighted as shown below.

Press on A and drag down to B to highlight the score cells.

13  Click on the A+ grade on the tool bar. A score of 25 is entered for each student. Try clicking on other 

grades and special scores on the tool bar. 

Ms. Demo has decided to begin assessing her students based on her school district’s educational standards. 

She also has decided to ease into standards-based grading by focusing just on science at first. If you are 

interested in learning about Easy Grade Pro’s standards-based grading tools,   proceed with the next set of 

steps. Otherwise, skip ahead to step 19.

14  Click on the Standard tab or choose Standard from the Chart menu.

You should be viewing the Standard chart in the class Quarter 2-Science-1. Notice that there is a second 

tool bar with tabs labeled 1-Assign. and 1-Student. Below these is a menu with the name of an assignment. 

To the right, are three tools. Make sure that the 1-Assign. tab is selected.

15  Press on the menu and choose 11. Star Lab. Or click on the Next Item tool    until the menu dis-

plays 11. Star Lab (shown above). Note that the Star Lab assignment will appear in the first column to the 

right.
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With Easy Grade Pro’s standards-based grading features, every assignment can have up to ten standards 

linked to it for independent scoring. These standards can be very diverse from having to do with spell-

ing, completion, effort, skills and knowledge. Summaries of performance on standards can be viewed and 

printed that are independent of any specific assignment. In the next step, you’ll select three knowledge 

standards that correlate to the Star Lab activity. 

16  Press on the Standards tool   
1.
2.   and, from the menu that pops up, select the following standards: 

ES1.4A, ES1.4B and ES1.4C.  You’ll know that you’ve selected them if they appear in the columns to the 

right of the Star Lab column as shown below.

Ms. Demo did not need to type these standards into Easy Grade Pro. In fact, she easily imported them into 

this class from special plugin files.

At the top of each standard column is the standard’s ID -- a unique identifier for the standard. Below this 

is the standard’s text and a number that represents the value of the highest rubric label. Ms. Demo set up 

a single rubric as follows: Exceeds Standard (4.0), Meets Standard (3.0), Approaching Standard (2.0) and 

Below Standard (1.0). If she had wanted to, she could have set up multiple rubrics for her standards. 

Notice the blue color behind the standard text. This color indicates the level of the standard. In Easy Grade 

Pro, standards can be at three levels. By default, these levels are Standard, Strand and Indicator but these 

labels and colors can be changed.

Notice that the scores entered in steps 10 through 13 are present in the Star Lab assignment column. These 

scores could just have easily been entered in this chart instead of in the Score chart.

17  Click on the first score cell under the ES1.4A column. Notice that the grade clicks bar displays the ru-

bric labels. Enter scores on all three standards using the same techniques taught in steps 10 through 13.

18  When done entering the scores, click the Score tab or choose Score from the Chart menu. 
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Recall that Ms. Demo teaches two science classes and both have the same assignments. It is easy to copy 

assignments from one class to another. In the next few steps, you’ll do just that.

19  Using the Class menu on the tool bar, move to Quarter 2: Science-2. 

20  Click on the Copy Class Data tool   or choose Copy->Assignments... from the Tool menu. The 

Copy Class Data window will open. The Copy window can be used to copy assignments, students, options 

and other class data. It can copy several items together and copy them to several classes at the same 

time.

21  First click on the Assign. tab at the top. In the top-left list, click on Quarter 2: Science-1. In the bot-

tom-left list, click on Quarter 2: Science-2. In the right-hand list, click on Star Lab. Finally, click Copy. The 

assignment will be copied from Science-1 to Science-2. After the window closes, the first score cell for the 

new assignment will be selected, ready for you to enter scores.

The rest of this lesson will focus on entering scores for the copied assignment. You’ll use a very powerful 

tool that allows you to easily enter scores from a mixed stack of papers. Since you don’t actually have the 

student papers, you’ll simply pretend.

22  Click on the Find    tool  on the tool bar or choose Find from the Tool menu. The Find window 

will open.

23  Select Use Continuous Search Mode. Then click Exit -- you must close the Find window. The continuous 

search mode causes Easy Grade Pro to return to the Find window after every score is entered. This means 

that whenever the enter key is pressed, or whenever a grade is clicked on the tool bar, the Find window will 

reopen automatically.
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24  In the score chart, select the first score cell for the Star Lab assignment. This score cell is for Kelly Arm-

strong.

25  You will be pretending to enter scores directly from student papers. Follow these steps:

Paper #1: In Kelly Armstrong’s score cell, type 25 and press enter. The Find window will reopen.

Paper #2: The next paper belongs to Josef Talbo. In the Find window, type the letter T and notice that Easy 

Grade Pro completes it with ‘Talbo, Josef ’. Press enter. Now click Sat on the tool bar. The Find window 

reopens.

Paper #3: Tad Nguyen earned a 20. Type an N in the Find window and press enter. Type a 20 and press 

enter again.

Paper #4: Justin Bronin earned an 18. Type the letter B and notice that Easy Grade Pro completes it with 

‘Benjamin, Atunde’. Type the letter R and notice that Easy Grade Pro completes it with ‘Bronin, Justin’. 

Press enter. Type his score.

Go ahead and finish the remaining scores on your own -- just make them up! When you are done, be sure 

to deselect the Use Continuous Search Mode box so the Find window will stop reappearing. By the way, 

the Find window and the continuous search mode work in all of Easy Grade Pro’s charts: score, atten-

dance, seat, student, assignment and standard.

Lesson 3: Options and Tools
This lesson, which has been divided into five short parts, will guide you in an exploration of some of the 

options and tools within a gradebook. To begin this lesson, the Demo Gradebook must be open.

Part A: Gradebook Options and Class Options
Easy Grade Pro offers an abundance of options to accommodate your personal style. Some options, such 

as font and font size, affect the entire gradebook and are called Gradebook Options. But many options 

apply only to a single class; these are called Class Options and include items like grade scales, categories, 

weighting, calendars, colors and more. In this section, you’ll view both types of options. Don’t forget to 

utilize the Help tools to gain additional information about the options.

1  Select Gradebook Options from the Edit menu and explore all tabs. Click Done.
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2  Select Class Options from the Edit menu and explore all tabs. Click Done.

Part B: Adding a New Data Column
You have many ways to configure the charts so that they best suit your needs. In the score chart, for ex-

ample, special columns can be added which show class rank, points, or nearly any other data about your 

students. The next few steps will show you how to do add special columns.

1  Switch to the score chart view of Quarter 2: Reading. Above the column of student names, press on the 

11 of 11 Students title (shown below).

����������

2  From the menu that appears, choose Add NEW Column (first item). A new column will appear to the 

immediate right. It will also be titled 11 of 11 Students.

3  Press on the new column’s title and choose Main Grades->Class Rank. The title and content of the col-

umn will change to display the rank for each student. 

4  To resize the new column, move the mouse so that the arrow is over the line to the right of the Class 

Rank title. Press and drag the line to the left or right.

���������������������������������
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5  To relocate the new column, press on any cell below the title. The cursor will change to a hand. Drag the 

column left or right to the new position and let go. 

6  Press on any student’s name. The cursor will change to a hand but you won’t be able to drag the column 

left or right. However, you can drag the student’s row up or down to a new row position. Try moving stu-

dents to new rows. This also works on assignments: press on an assignment’s title and drag left or right to 

move the assignment to a new location.

Add up to eight data columns in both the score and attendance charts. Resize and relocate them. Go ahead 

and explore. 

Part C: Using Filters
Easy Grade Pro allows you to configure the charts so that they display just the students, assignments, scores 

or attendance dates that you would like to see. In this section, you will explore ways to do this.

1  Switch to the score chart and explore the four filter menus (circled below).

2  Switch to the other charts (except seating); find and explore the filter menus.

Press on the four menus (circled) to filter students and assignments and to set the display of scores.

Part D: Setting the Display of Seats and Furniture
The seating chart allows you to place seats and furniture nearly anywhere. It also allows you to change the 

shape, size, rotation and color of these items. Use the Chart menu or tabs to switch to the seating chart. 

Then try these:

•  Move a single item by dragging it.

•  Swap two seats by dragging one to another. (The upper-left corners must be aligned.)

•  Select more than one item by clicking while holding down the shift key or by dragging a rectangle 

around the seats.

•  Drag a group of selected items.

•  Double-click on a seat to open the Seat Options window. Try different settings.

•  Double-click on a piece of furniture to open the Furniture Options window. Try different settings.
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Part E: Other Tools and Windows
Many special windows can be opened by double-clicking, right-clicking and control-clicking in different 

regions of the charts. Try these suggestions for opening special windows in the score chart:

•  Double-click on a row number or column number to open the Summaries window for that item.

•  Double-click on any student or assignment name to open the Records window.

•  Double-click on any score cell to open the Score Note window.

•  Single-click in the small box to the left of the first score for any student to open the Lock/Curve Grade 

window.

•  Right-click (Windows) or control-click (Macintosh) on student names and assignment names.

Lesson 4: Working with Reports
In this lesson, you will be taken through the steps of selecting a report, its range and options. Then, instead 

of printing the report, you will preview the report on screen. The Demo Gradebook should be open. You 

can be in any class.

1  Click the Print    tool  on the tool bar or choose Print from the File menu. The Print Reports win-

dow will open. 

2  Choose a Report from the Reports menu near the top. Then explore all the tabs and buttons in the win-

dow. Notice how, as you change options, the preview changes immediately. If the preview is too large to 

view in its entirety, press on it with the mouse to grab the page and drag it about. Try different reports and 

different options. Remember: explore!

3  Click the Cancel button to close the Print Reports window. 

This is the end of Lesson 4 and the end of this tutorial. By the way, the changes that you made during these les-

sons have been automatically saved. With Easy Grade Pro, changes are always automatically saved. If you are 

ready to create your a gradebook for your own classes, proceed to the next chapter.
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Classes3

This chapter is for you if you if you are ready to begin using Easy Grade Pro to manage your student data. 

It will take you through the steps of creating a gradebook, adding classes and a few other basic tasks.

Starting a New Gradebook
You’re likely to need only a single Easy Grade Pro gradebook at a time. Since a gradebook can hold up to 

250 classes in up to ten terms you might want to use a single gradebook for an entire school year because 

it saves time and minimizes the duplication of efforts. Since a gradebook can become large you may want 

to create a new gradebook for each major term. Don’t do this, however, if the student grades in one term 

must be combined with the grades in another.

To start a new gradebook:
1  Start Easy Grade Pro. On a Macintosh, do this by double-clicking on the Easy Grade Pro 3.6 icon in the 

Easy Grade Pro folder. On a Windows computer, do this by clicking on Start, choosing Programs, and then 

choosing Easy Grade Pro. A title window will appear (shown below).
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2  Click the Create a New Gradebook button. The standard Save window will open where you can name and 

choose a location for your new gradebook.

3  In the Save window, type the name of your new gradebook. What name should you give it? We recom-

mend that you use your last name and the year (or term) such as Smith 2003-4 or Smith Winter Term 2003.

4  Choose the location for your gradebook. We recommend that you save it to your computer’s Desktop 

because 1) you’ll have ready access to it, 2) you’ll be able to open it easily by double-clicking its icon, and 3) 

the Desktop is a reliable place to store an important file since it is part of your computer’s hard drive. 

5  Click the Save button. Easy Grade Pro will create an empty gradebook and open the gradebook’s win-

dow.

FAQ: Easy Grade Pro saves automatically. What does this mean?
Like many programs that deal with large amounts of data, Easy Grade Pro automatically saves your changes while 
you work. When you switch classes, switch charts, choose most menu commands or even pause for a few moments, 
you trigger Easy Grade Pro’s save feature, causing it to write changes to your gradebook file.

In Easy Grade Pro’s File menu, there is no Save command; you never manually save your work. However, there is a 
Save Copy command and, when you close a gradebook, there may be a prompt for saving a copy. It is highly recom-
mended that you make copies of your gradebook but keep in mind that these are copies -- they should never be used 
unless something happens to make your original gradebook unusable.

Adding Classes to a Gradebook
In Easy Grade Pro, a class is a collection of students and their data for a single subject in a single term. A 

subject might be Reading, Math, Physics I or Art History. A term might be Quarter 1, Semester 2 or even 

Final Exam.

It is generally best to have a one-to-one correspondence between the classes that you teach and the classes 

in your gradebook. If you teach five subjects this term, you probably should have five classes in the cur-

rent term of your gradebook. If you teach multiple sections of the same class (i.e. three sections of Earth 

Science), there generally is no benefit to combining the sections into a single class. Easy Grade Pro makes it 

easy to switch from one class to another and to copy assignments and options from one class to others. By 

keeping your classes separate, you will be able to view summaries of each making it easy to make compari-

sons. If you are an elementary teacher with multiple reading (or math) groups from your main group of 

students, you can choose to have all groups in a single class or break them into separate classes. Easy Grade 

Pro can handle either setup well.

If you have just created a new gradebook, one without classes, a window will automatically appear (shown 

below) directing you to add classes. 



21CHAPTER 3: Gradebooks and Classes

Obviously, a gradebook without classes is not very usable so it is a good idea to click the Add Classes but-

ton. Here are some general guidelines about adding classes to a gradebook:

•  Add a class to the gradebook for each class you teach in your current term only.

•  Do not add classes for future terms; it is best to add them later.

To add a class:
1  If your gradebook has no classes, click the Add Classes button. Otherwise, choose Add Class from the 

Tool menu. In either case, the Records window will open (shown below) to an empty class record.

2  Type the name of the class in the Class/Subject Name field and press tab. Be sure to use a unique name 

for the class. Examples include Math, Reading, English(1), English(2), etc. Do not include a term name 

with the name of the class.

3  (Optional) Edit the Class Weight and press tab. It’s not likely that you’ll ever need to change the class 

weight. It is used only in the multi-class progress report and the multi-class gradesheet report when a 

student’s weighted average or GPA for several classes is calculated. In most cases it should be left at 1.00. If 

you have a class that is worth half of a normal class, set the class weight to 0.50 and so on.

4  Edit the Term Labels in the column on the left so that they match the term labels used by your school. 

You can use First 6 Weeks, Quarter 1, Semester 2, etc. If you will give a final exam that must be weighted, 

then you must add the final exam as a term. Changes made to these labels will apply to all classes so you 

won’t have to change them again in the gradebook.

5  Select the current term for the class by clicking in the box to the right of your current term’s label. A 

check or ‘x’ will appear. You must select at least one term and you may select more. We recommend that 

you select your current term only. Later on, when you are ready to begin the next term, you can add a new 

term.

6  (Optional) Edit the Custom Labels and enter Custom Data. These eight custom fields are very important 

to some users of Easy Grade Pro but are not used by most. They are used to hold course number, section 

number, teacher name and other course-specific data. These values are critical if you will be importing 

your student rosters from school administration software and exporting grades. These are also used when 

uploading internet reports to Edline or Basmati. Generally, you won’t use them unless your school in-
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structs you to do so.

7  (Optional) To add more classes, click the Next Class button. Then repeat steps 2 through 6.

8  Click Done to close the Records window. To switch to the different classes, use the Class menu or the 

Prior Class  C  and Next Class  C  tools. 

Managing the Classes in your Gradebook
You can add, delete and rename your classes. You can sort them into any order. Terms can be added to 

classes and terms can be renamed. This section explains how to perform these basic tasks.

To add a class: 
To add a new class, follow the steps found on the prior page. Note: if you need to add a new term to an 

existing class, see To add a term to an existing class below. 

To delete a class: 
1  Choose Delete->Class from the Tool menu. The Delete Records window will open with a list of all the 

classes in the gradebook.

2  Select the class or classes to delete from the list. Press on the blue arrow to select or deselect all items in 

the list.

3  Click the Delete button.

To rename a class:
1  Use the Class menu to switch to the class.

2  Choose Records from the Chart menu or click the Records tool  .

3  Select the Classes tab.

4  Edit the name of the class and click Done.

To sort or reorder your classes:
1  Choose Sort Classes from the View menu. The Sort Classes window will open.

2  Press on classes and drag them to the desired locations in the list. Use the sample class menu at the top 

of the window to view the effects of your changes.

3  Click Done.

To add a term to an existing class:
We recommend that you wait until right before the start of the new term before adding a term to a class.

1  Use the Class menu to switch to the class.

2  From the Tool menu, choose Term Tools->Start New Term. Easy Grade Pro will automatically put a 

check or ‘x’ for the appropriate term in the Records window for the class. It will then switch to the new 

term and automatically copy the students to it from the prior term. Be sure to take a look at Working with 

Terms on page 81 for a thorough discussion of this topic.

To rename a term:
1  Choose Records from the Chart menu or click the Records tool  .

2  Select the Classes tab.

3  Edit the name of the term. This change applies to all classes in a gradebook.
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Easy Grade Pro attempts to accommodate your grading style by providing options on two levels: class as 

well as gradebook. Class options apply to a single class in one term. Gradebook options apply to all classes. 

Since getting Easy Grade Pro to match your style is so important, this chapter should not be missed!

About Class Options
Each class within your gradebook has its own grading scales, score categories, special scores, attendance 

categories and other options. Together, these are known as class options because they are stored with the 

class and are unique to it. 

A class does not have options until you view it for the first time; Easy Grade Pro will automatically copy 

options into it from another class, either from a prior-term class or from an adjacent one. If there is no 

‘other’ class because it’s your first one, Easy Grade Pro will copy from a built-in set and display a message 

letting you know what it has done. Since the built-in set is unlikely to match your style, you’ll want to edit 

it as soon as possible, ideally before you view other classes.

To view or edit the options, choose Class Options from the Edit menu or click the Class Options tool  

.  In the window that opens, you’ll find a series of tabs, one for each type of option. There is a section 

in this chapter for the options found under each tab except for the Rubric tab, which is covered on page 62, 

and the Term tab, which is covered in page 81.

Keep in mind that the changes you make to the options will have no effect on other existing classes in your 

gradebook. This allows you to have options that vary from class to class and term to term. However, since 

you’ll likely have some options that you’ll want the same in all classes, be sure to read the section Copying 

Class Options to other Classes on page 31. 

Class Options: Grade Scale
A grade scale is used to convert the percent on an assignment, a category average and the overall average to 

some meaningful label called a grade. For example, it may be used to convert a 98% to an A+. 
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A scale consists of one or more grades with a minimum or cutoff percent for each. Grades can be letters 

(A,B,C), words (Outstanding, Satisfactory) or numbers (4.00, 3.00). A class may have multiple scales. Each 

student is assigned the first grade scale but you can have different scales for different students. You can 

even assign scales to score categories in case you wish a category of assignments to use a certain scale. 

To edit grade scale options:
1  Choose Class Options from the Edit menu and select the Grade tab.

2  To view or edit a scale, first click on its row number. The grades and minimum percents will appear in 

the list to the right. 

3  To create a new scale, click the blue button above the left list and choose New Item. Type the name of the 

scale and then type the grades and minimum percents in the list to the right. The minimum percents must 

be in descending order and the last percent must be 0. Use the small blue arrows to insert or delete a row 

anywhere in a scale. 

4  To duplicate or delete a scale, click the blue button above the left list and choose the appropriate item. 

Then click the appropriate button below the list.

5  The first grade scale in the list is the most important one because it is initially assigned to all students. To 

move a scale to the top position, press on its row number and drag.

FAQ: What is grade-clicking? How does it work?
Easy Grade Pro allows you to enter scores by clicking on grade buttons in a process known as grade-clicking. You can 
also enter scores by typing grades if the ‘Allow typing of Grades and Special Scores’ option is on in the Gradebook Op-
tions window.

What score does a student get when an A+ or C+ is clicked or typed? The score is based on the grade-click value of the 
grade. The grade-click value for the top grade is always 100%. For other grades, it is the average percent for the grade. 
If an A+ is the top grade, the student will get a score that is equivalent to 100%. If a C+ ranges from 76% to 80%, the 
student will get a score that is equivalent to 78%. 

Grade-click values are automatically set and editing is usually unnecessary. To edit them, click the blue arrow above 
the scroll bar on the right in the Scale view of the Class Options window.
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6  Set the rounding level. Rounding options include whole numbers, tenths and hundredths, and are used 

whenever percents are calculated. As an example, suppose a student has earned 89.638%. After round-

ing, the number displayed will be 90% for ones rounding, 89.6% for tenths rounding and 89.64% for 

hundredths. Ones rounding results in cleaner looking numbers. Hundredths rounding results in greater 

accuracy. For many teachers, tenths rounding offers a good compromise. 

7  To assign a scale to a student (other than the first scale), exit from the Class Options window and choose 

Students from the Chart menu. In the Grade Scale column, select a scale for the student.

8  To assign a scale to a score category (other than the student’s scale), click the Category tab in the Class 

Options window and make your selection from the pop up menu after the category’s name.

FAQ: How do I set up my 5-point (or some other point) grading system? (Part 1)
The simplest way to do this is to set the maximum score on assignments to five and type the numbers one through five 
as scores into score cells. 

Before you do this, be sure you understand how this will affect student percents: since a score of 1 out of 5 is a 20%, 2 
out of 5 is a 40%, etc., students may have assignment and overall percents that are much lower than what is typically 
considered acceptable. To compensate for this, you can create a grade scale that looks something like this: +5 (90%), 
+4 (70%), +3 (50%), +2 (30%), +1 (10%) and +0 (0%). You will almost certainly want to hide percents in reports 
so you don’t get questions from parents like “My daughter has a 49% and this is OK?”. You might be wondering why 
we added the ‘+’ before each grade -- this is so you can tell the difference between the number five and the grade of 
five onscreen and in reports -- grades and numbers are not the same!.

The biggest drawback of this method is that, once set up, you must use it for every assignment in the class. Since a 
grade scale applies to a student, you don’t want a situation in which a 50% is good on one assignment (grade of +3) 
but bad on another (grade of F). This topic is addressed again in Part 2 on page 28.

Class Options: Score Category
Whenever you add an assignment to a class, a score category must be selected. Categories are used in 

graphs, summary charts, filters and reports. They help provide useful information about a student’s per-

formance. They can also affect a student’s overall grade if the weighted-categories option is turned on. A 

class can have up to fifteen score categories.

To edit category options:
1  Choose Class Options from the Edit menu and select the Category tab.

2  View and edit the category names. Since each class has its own set of options, you can use subject-spe-

cific names such as Lab Activity. 

3  Turn on category weighting (click the Yes button) if you want your categories to have a certain propor-

tional effect on overall grades. Enter percents in the Weights column so that their sum is 100%. To learn 

how category weighting affects calculations, refer to FAQ: How is a Student’s Overall Grade Calculated? on 

page 51. 

4  Grade Scale Option. If you would like to use a special grade scale for all assignments in a certain catego-

ry, select it from the Grade Scale Options column. As an example, you can have a category named Effort 

that uses a +1, +2, +3 grade scale. Easy Grade Pro will use the category’s assigned grade scale in the score 

chart, in assignment graphs and in reports. Grade scales are created in the Grade view of the Class Options 
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window.

5  Dropping Option. When an assignment is added to a class, Easy Grade Pro allows you to set the status of 

the assignment to Can be Dropped. From among these, it will drop the single most-damaging score for stu-

dent. If you’d like Easy Grade Pro to drop more than one, then select the number of scores to be dropped 

from the Dropping/Extra Credit column. You are limited to four dropped scores. For more information on 

dropping, see Adjusting Grades: Dropping, Extra Credit, Curving and Locking on page 53.

6  Extra Credit Option. To make one of your categories an extra credit category, select Extra Credit from 

the last column. This will cause the name of the category to be changed to Extra Credit. Be careful if you 

have category weighting turned off: all points earned by a students on assignments in this category will be 

added to the student’s point total.  However, if you have category weighting turned on, then you can set 

a percentage limit, or weight,  on the value of the extra credit. For more information on extra credit, see 

Adjusting Grades: Dropping, Extra Credit, Curving and Locking on page 53.

Class Options: Score Footnote
Score footnotes are short comments that can be attached to scores to provide additional meaning. They 

can be included adjacent to scores in printed reports. Footnote text can be edited in the Footnote view of 

the Class Options window. Up to nine footnotes can be set up but a score can have only one footnote at-

tached to it. For more information, see Adding Footnotes and Notes to Scores on page 50.

Class Options: Special Score
Special scores are scores that can be used in place of numeric scores to provide special meaning. Easy 

Grade Pro provides a variety of special scores that you can use, modify and delete. In addition, you can 

create your own. 

Here is a list of some of the most used special scores with suggestions for use:

ex, short for excused, is for an assignment that has not been submitted and not required of the student, 

perhaps due to a late enrollment or other special circumstance. It has no value and does not affect the 

overall grade.

cr, short for credit, is for an assignment that has been submitted but is not to be graded. It has no value 

and does not affect the overall grade.

ab, short for absent, is for an assignment not submitted due to an absence. It has a value of 0%. It 

•

•

•
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implies that the assignment can and should be submitted for a new grade. This score causes the assign-

ment to appear in missing work reports.

mi, short for missing, is for an assignment not submitted and for which no valid excuse exists. It has a 

value of 0%. Teacher policy determines how this grade can be changed. This score causes the assign-

ment to appear in missing work reports.

inc, short for incomplete, is for an assignment that has been submitted but must be redone or complet-

ed. It has a value of 0%. It implies that the assignment can and should be completed for a new grade. 

This score causes the assignment to appear in missing work reports.

To edit special score options:
1  Choose Class Options from the Edit menu and select the Score tab.

2  In the Score Names column, put the name to be used as a key in reports.

3  In the Code column, put the text that will be used as the score. To avoid confusion, we strongly rec-

ommend that you not use numbers unless you include other symbols. For example, consider using ‘+1’ 

instead of ‘1’.
 

4  Optionally, you can include a single Shortcut key that, when pressed, enters the code into a score cell. If 

used, it must be unique in the list.

5  The Value% of a special score should be blank or between 0 and 100%. If you leave this blank, the spe-

cial score will have no affect on a student’s grade.

6  If you would like the score to be picked up when a missing work report is printed or when a missing 

work filter is used, be sure to set the Missing attribute.

For information about using special scores, refer to the section Entering Scores starting on page 47.

FAQ: How do I enter a check  mark as a special score?
Easy Grade Pro allows you to use nearly any font on your computer that includes the alphabet, numbers and punc-
tuation. On Macintosh computers, most fonts that have these characters also have a check mark. Simply type option-
v to get it. On Windows computers, the check mark is only found in specialty symbol fonts that are not suitable for use 
in Easy Grade Pro because they do not include alphabetic and numeric characters.

•

•
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FAQ: How do I set up my 5-point (or some other point) grading system? (Part 2 )
(This is a continuation of a FAQ started on page 33). 

Because of the tremendous range of percents that occurs when the maximum score on an assignment is as low as 5 
(i.e. 1/5 = 20%, 2/5 = 40%, 3/5=60%, 4/5=80%, 5/5=100%), the use of special scores instead of numbers may be a 
better way to set up a 5-point system. Your special scores could be +5 (100%), +4 (90%), +3 (80%), +2 (70%) and 
+1 (60%). If you were to enter a +5 as a score, the student would receive 100% of the maximum score; for a +4, the 
student would receive 80% and so on. 

This use of special scores has advantages over the use of true numbers: 1) the range of percents is more typical, 2) you 
don’t have to use a modified grade scale, 3) percents can be displayed in reports if you choose, and 4) you don’t have 
to use a maximum score of 5 on every assignment -- use whatever you want on any assignment!

Create your special scores in the Score view of the Class Options window. Put the ‘+5’ and other scores in the Code 
column. Be sure to add the ‘+’ or some other symbol to minimize confusion with true numeric scores. Put the percents 
in the Value% column. Be sure to create a shortcut for each to make data entry of your special scores very fast.

Class Options: Attendance Category
Any class can be used for recording student attendance marks. If you are an elementary teacher, you may 

find it best to use your first class of the day for recording attendance; when you print multi-class progress 

reports, Easy Grade Pro will automatically find and use the right class when printing the attendance chart 

portion of the report. If you are a secondary teacher, you can record attendance in every class.

To record attendance marks in a class, attendance categories and a term calendar must be set up. (Setting 

up a calendar is discussed in the next section). You can set up to fifteen attendance categories. An atten-

dance category has five attributes. The category, such as Excused Absence, is the full name of the category. 

The master category, such as, Absent, names the major grouping that the category belongs to. The code, 

such as AE, is the one- or two-character mark that is entered in an attendance cell. The value is used when 

calculating totals and should be 1.00 for full-day marks, 0.50 for half-day, etc. Easy Grade Pro will calculate 

totals for all of your categories and master categories. The auto-fill score is used if you want to have Easy 

Grade Pro enter scores in the score chart based on attendance. For example, you can have Easy Grade Pro 

enter a special score of ab for students who are marked absent on a day when an assignment is due. For 

more information on this, refer to the section Auto-filling Attendance Scores starting on page 58. 
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To edit attendance category options:
1  Choose Class Options from the Edit menu and select the Attendance tab.

2  To edit the list of Master Categories, first press and hold on any row in the Master Category column. 

From the menu that pops up, choose Edit this Menu. In the window that appears, edit the list of master 

categories.

3  For each of your attendance categories, select the Master Category and enter the category, code and 

value. Optionally, enter an auto-fill score.

Once you start using your attendance codes, it is important that you don’t change their order or meaning 

and that you don’t delete items that are in use.

Class Options: Calendar
Calendar options are used to set the days of the week, the starting and ending dates and no-school days. 

These only need to be set if you plan to use the class for recording attendance marks. 

In Easy Grade Pro, a class is an entity within a single term only; the calendar that you set up should reflect 

this. If you use Easy Grade Pro’s Term options to combine student data across terms, you will be able to 

obtain attendance totals for multiple terms. This is explained in Working with Terms on page 81.

To edit calendar options:
1  Choose Class Options from the Edit menu and select the Calendar tab.

2  Set the days of the week that the class meets. If your class meets on varying days, be sure to select any day 

that the class might meet. Once you begin recording student attendance marks, the days of the week can-

not be changed.

3  Set the first day of the term by clicking on the date in the first calendar. Once you begin recording atten-

dance marks, the first day of the term can’t be changed.

4  Set the last day of the term and the no-school days on the other calendars. These can be changed at any 

time.
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Class Options: Seat Format
If you plan to use the seating chart for a class, you can set the size, shape, name format and attendance for-

mats for all of the seats in the Class Options window. Additional options, such as color and rotation, can 

be set for individual seats but must be set in the actual seating chart.

To edit seat options:
1  Choose Class Options from the Edit menu and select the Seat tab.

2  To change the shape, drag the box in the lower-right corner of the sample seat.

3  To change the name format or to allow entry of attendance or scores into seats, use the buttons and 

menus on the right.

To set options for individual seats:
1  Choose Seating from the Chart menu.

2  Double-click on a seat to open the seat’s format window.

3  Change the rotation, color and locked status as desired. Locking a seat prevents the seat from being 

moved or being affected by sorting.

Class Options: Color
Color options allow you to set the background and grid colors. You can choose to have a solid background 

color or have alternating, complementary row colors. You can color-code scores and attendance marks for 

emphasis. 

To edit color options:
1  Choose Class Options from the Edit menu and select the Color tab.

2  Use the Grid Color and Background Color buttons to open a window where you can choose new colors.

3  Move the Gradient slider to the left to have the background color used on every row. Move the gradient 

slider to the right to have alternating row colors. Contrast between the alternating colors increases as the 

slider is moved to the right.

4  Use the Score Colors and Attendance Colors tabs to switch between setting colors for the score chart and 

for the attendance chart. You may set colors for both charts.

5  Use the Select colors based on menu to choose the basis for color selection.
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6  Use the six pop up menus and six buttons in the bottom half of the window to select specific colors for 

scores and attendance marks.

7   Turn on the Show colors as backgrounds in score cells option if you’d like your attendance colors to ap-

pear as the background colors in score cells. This feature makes it easy to see if a student was absent on the 

day the assignment was due. This option affects the score, seat and standard charts.

Copying Class Options to other Classes
One of the most important features in Easy Grade Pro is the ability to copy some or all of your class op-

tions from one class to others using the Copy Class Data window. This can save you lots of time and help 

you ensure that your options are consistent across classes and terms.

To copy class options from one class to others:
1  Choose Copy->Class Options from the Tool menu or click the Copy Class Data tool    and select 

the Options tab. 

2  In the upper-left list, select the class to copy from. 

3  In the lower-left list, select the class(es) to copy to. Be sure that you don’t select the class that is selected 

in the upper list. To select multiple items, hold down the shift, ctrl (Windows) or command (Macintosh) 

key while clicking.

4  Select the options you wish to copy in the list on the right. Use the blue arrow button to select or dese-

lect all list items. To select multiple items, hold down the shift, ctrl (Windows) or command (Macintosh) 

key while clicking.
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5  Check all of your settings to ensure that you are copying the right options to the right classes.

6  Click the Copy button.

About Gradebook Options
Unlike Class Options, Gradebook Options are settings that affect your entire gradebook. You can set the 

font, the order of first and last names, passwords, types of warnings and whether you want to be able to 

directly type grades or special score shortcuts. You can create reusable text items for notes and reports, 

create filters for showing just the desired students and assignments, customize the labels used in student 

reports and even set up your gradebook to be used with EGP Clipboard, the Palm OS companion to Easy 

Grade Pro.

To view or edit these options, choose Gradebook Options from the Edit menu. In the window that opens, 

you’ll find a series of tabs, one for each option group. The remaining sections in this chapter describe the 

options found under each tab.

Gradebook Options: General
Use General options to set the primary options that affect how your gradebook looks and behaves.

To edit General options:
1  Choose Gradebook Options from the Edit menu and select the General tab. Notice that there is a list of 

categories of options with a graphic to the left of each.

2  Press on the graphic to the left of an item to reveal the options in that category. These are explained next.

Display Options
Font Options. Set the font and font size to be used in the main charts. This does not affect reports.

When a cell is selected highlight... minimally, entire row, entire column or entire row and column. Use this 

to control how much of a row or column is highlighted when a cell is selected. For maximum readabil-

ity, have the entire row and column selected. 

•

•
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Display student names as...  Last, First or First Last. This affects onscreen charts and reports. It does not 

affect the seating chart which has its own option in the Class Options window.

Display assignment scores...  as raw scores (20), as percents (80.0%), as grades (B-) or using Assignment 

Record settings. The assignment record setting can be found by double-clicking on an assignment’s 

name in the score chart or by choosing Assignment from the Chart menu. This option can also be set 

by pressing on the small filter menu next to the first score for the first student in the score chart. 

Display overall grades as... as percents only (100.0%), grades only (A+) or percents and grades (100 A+ ).

Display standard grades as... numbers only (3.00), rubrics only (Meets Standard) or numbers/rubrics 

(3.00/Meets Standard). This option can also be set by pressing on the small filter menu next to the first 

score for the first student in the standard chart. 

Show score/attendance colors. Use this to turn on or off the colors for scores and attendance marks in 

the main charts. To set the colors, choose Class Options from the Edit menu and select the Color tab.

 Hide assignment dates in Score and Standard charts. If dates are not relevant to your assignments, turn 

this option on. Dates will be hidden onscreen as well as in certain reports.

Show warning symbol for students with missing work. This symbol appears as a  . It will appear only if 

the student has scores that count as missing in the Class Options window, Score tab.

Score Entry Options
Allow typing of.... Special Score Shortcuts and Grades and Special Scores. The first item allows you to 

type a shortcut like a and have Easy Grade Pro automatically enter an ab and jump down to the next 

cell. Special scores and their shortcuts are set in the Score view of the Class Options window. The sec-

ond item allows you to directly type an A+, A or ab -- any grade or special score. This option can also 

be set by pressing on the small triangle to the left of the grade-click palette.

When a special score shortcut is entered.... move down, move right, and remain in the same cell. If you 

typically enter scores down a column, from one student to the next, set the first option. But, if you 

typically enter multiple scores for one student before moving down to the next, then you’ll appreciate 

the second option. The third option is for those who do both and would rather have to use an arrow 

key after entering a special score to choose the direction of movement.

When the last score in a column is entered.... remain in the same cell, move to the top of the next column, 

and move to the top of the same column. If you first enter scores into a paper gradebook, you’ll find the 

first option to be time-saving because it allows you to enter scores the fastest.

 Display a warning when a score.... is changed, exceeds the Maximum. These warnings can help prevent 

•

•

•

•

•

•

•

•

•

•

•
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accidental changes. Only a single warning is given when you exceed the maximum score in case you 
are entering a series of scores with extra credit.

Security/Password Options
Full Access Password. If you would like your gradebook to require a password to be entered whenever 

you open it or after you choose Lock from the File menu, then enter a password here. 

Restricted Access (RA) Password. If you would like others to be able to open your gradebook but you 

would like to restrict what they can do, then set a password here and set the ...allow RA user to options 

as desired. To turn on the RA mode choose RA Mode from the File menu or select the RA Mode tool  

RA . To turn off the RA mode, choose RA Mode as before. The password window will appear and 

the teacher password must be typed to regain full access. 

FAQ: I don’t remember the password. How do I get back in?
If you are unable to get into your gradebook, call Orbis Software for help. If you are a registered single-user license 
holder or if you are the contact person for a school that holds a registered site license, you will be given a special 
one-day password that will allow you to open the gradebook and set a new password. See www.easygradepro.com for 
phone number and times in which this support is available.

FAQ: When I switch classes, my gradebook displays a message ‘Gradebook is locked --  changes could not 
be saved’. What is happening?
First of all, this message has nothing to do with password protection.  Rather, it is Easy Grade Pro’s way of telling you 
that the computer is not allowing it to save your changes. There are many possible causes. Check that your gradebook 
is not in a location where you don’t have write-permissions. Make sure you are logged into the computer with the 
right login account. On Windows, open the Properties window for your gradebook and make sure the Read Only 
attribute is not turned on. On Macintosh, open the Get Info window for your gradebook and make sure the Locked 
attribute is not on. As a last resort, open your gradebook, choose Save Copy from the File menu and save a copy of 
your gradebook to a location where you have write-permissions such as your Documents folder. Then open the copy. 
If it works properly, use it instead.

Backup Options
Anyone who has used a computer for long knows that computers are susceptible to all sorts of problems. 

Problems may be inevitable but their damaging effects can be minimized if one has a good backup plan in 

place. A good plan requires multiple, regular backups. Easy Grade Pro’s backup options make this easy:

When closing a gradebook... do not save a backup, prompt to save a backup or automatically save a back-

up. We recommend that you select the third option so that a backup is made every time you close it. 

Default backup Name... ‘Year-Month-Day.egp’, ‘Day of Month.egp’ and ‘Day of Week.egp’. With these 

options, you’d get gradebook names like 2006-11-06.egp, 6.egp and Monday.egp respectively. So which 

is best?  The first option offers the greatest security but it will also result in the greatest number of 

backups by the end of the school year because you’ll end each day with a unique backup that will never 

get replaced by the backup made on another day. With the second option, the backup made on the 

sixth day of the month will get replaced by the backup made on the sixth day of the next month. And, 

with the third plan, the backup made on Wednesday of this week will get replaced by the one made 

next Wednesday. If you have the space on your hard drive, server or flash drive, we recommend the 

first option.

•

•

•

•
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Default backup Location... You can choose to have the backup saved automatically to a Gradebook 

Backups folder in your Documents folder, on your Desktop or to a location of your choice. For the 

greatest security, we recommend the third option if you can set the save location to a server or to a 

flash drive that you can store at another location when you aren’t using Easy Grade Pro.

Tool Options
Show Tool Bar. The tool bar consists of up to twenty tools near the top of the main charts. This can be 

turned off to maximize the number of student rows visible on your monitor.

Show Mini-Summary. This small window can be used to display graphs and lists that are updated as 

you enter student data. You can choose to have this small window visible in none of the main charts, in 

the charts that have a nice empty box for it in the upper-left corner (Score, Attendance and Standard) 

or in all charts. See the section titled Using the Mini-Summaries Window on page 89 for more informa-

tion.

Automatically position Mini-Summary based on chart. To have the mini-summary stay at the some 

location regardless of chart, turn this off. Otherwise, the mini-summary will move to a pre-set loca-

tion based on the current chart.

Show Tabs for Score, Attendance and other charts. These tabs appear near the top of the main charts. 

This can be turned off to maximize the number of student rows visible on your monitor.

Gradebook Options: Filters
Filters are used to show just the students, assignments and scores you want to see in the charts. For exam-

ple, a filter can be set up to show the students and assignments in one reading group in your class. Filters 

can be used in all charts but the seating chart. Before creating your own filter, you should study the built-in 

filters to see how they were set up. 

To create a new filter
1  Choose Gradebook Options from the Edit menu and select the Filters tab.

2  Click the New Filter button. The New Filter window will open.

3  Enter a name in the Filter Name field. 

4  (Optional) Use the Keyboard menu to select a unique key to be used to activate your filter.

5  Your filter may contain individual filters for students, assignments and scores. Use the tabs to switch 

between these three parts. Under each tab, enter up to four rules. The rules can be connected using and or 

found in the small menus to the left. And connects two rules so that they must both be met while or allows 

•

•

•

•

•
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either rule to be sufficient. Each rule consists of a subject and a condition that are selected using menus. 

Depending on the type of condition, the rule may or may not have an object that must be completed by 

typing letters or words into a text field. Case is not important.

6  Be sure to test your filter; you may find that it needs refinement to work properly. Note: filters have no 

effect on students whose status is WD (hidden).

FAQ: I have a group of students (or just one student) with unique assignments. How can I create a filter to 
show just this group and its assignments?
The first step is to come up with a code for this group, such as RED. Choose Assignment from the Chart menu and 
put the code into the Note field of each assignment’s record. Choose Student from the Chart menu and put the code 
into one of the twelve custom fields of each student’s record. Now, create a filter that shows students with the code in 
the custom field and that shows assignments with the code in the Note field. If you have multiple groups of students 

and assignments in your class, you can create a filter for each group.

Gradebook Options: GPA
GPA, or grade point average,  is a numerical point value (i.e. 4.00) assigned to a student’s grade (i.e. A). 

The GPAs from multiple classes can be combined to produce a weighted, multi-class GPA. GPA can be 

displayed in certain charts and reports.

To edit GPA options:
1  Choose Gradebook Options from the Edit menu and select the GPA tab. 

2  In the Grades column (on the left), enter all grades (i.e. A+) that are in use in your gradebook in all of 

your classes. These can be entered in any order. 

3  In the Point Values column (on the right), enter a numeric point (i.e. 4.00) value for each grade. Values 

must be between 0.00 and 10.00.

To set the weights used when multi-class GPAs are calculated:
1  Choose Record from the Chart menu.

2  Select the Classes tab. 

3  Edit the Class Weight for each class.
To display GPA in the Score (or other) chart :
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1  In the Score chart, press on the column title above the column of student names (or an adjacent col-

umn) and, from the menu that pops up, choose Add NEW Column. A new column with student names 

will appear. Note: this menu item will become disabled if the eight-column limit has been reached. 

2  Press on the new column’s title to bring up the menu again, but, this time, choose Main Grades->GPA. 

The printed Score chart report will include this column as well.

To display GPA in the Multi-class Gradesheet report :
1  Choose Print from the File menu. From the Report menu, select Multi-class Gradesheet. Select the Op-

tions tab.

2  Press on the Grade display menu and choose show as GPAs. 

3  To include a column with weighted, multi-class GPAs, turn on the Include Multi-class Avg. option.

To display GPA in the Student Progress report :
1  Choose Print from the File menu. From the Report menu, select Student Progress.

2  Under the Options tab, turn on the Include Student Title Data option.

3  Open this option and from the Include menu, select GPA. To cause this to be a weighted, multi-class 

GPA, turn on the Include Multiple Classes (in each report) option.

Gradebook Options: Clipboard Text
Use clipboard text options to create and store sentences and paragraphs that can be used and reused in 

score notes, summary notes and student reports. There is no limit to the number of clipboard text items 

and each has a 32,000 keystroke limit. Numerous variables can be added to the text; Easy Grade Pro 

completes the variables with student data at the time the text is printed or pasted into notes. Spell-check is 

available to help ensure that your text is error-free. 
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To edit clipboard text options:
1  Choose Gradebook Options from the Edit menu and select the Clipboard Text tab. 

2  To edit an item, first select it in the upper list. The full text will appear below.

3  To create a new item, select the list item titled NEW ITEM. Then type the text.

4  To delete or duplicate an item, press on the small blue arrow above the list.

5  Use the Insert menu below the text to add text variables. Variables are automatically filled in with the 

specified student or other data at the time the text is pasted into a note or printed in a report. You may 

need to put a space before and after each variable to ensure proper spacing when Easy Grade Pro later 

substitutes the variable with student data. 

6  To check spelling, click the Spell button.

Gradebook Options: Report Labels
Report Label options allow you to change the titles and labels used in student reports. Easy Grade Pro has 

labels in three different languages (English, French and Spanish) and each can be customized. You can 

even create labels for a fourth language of your choice. By default, Easy Grade Pro assigns English to every 

student. To assign a different language, choose Student from the Chart menu and edit the items in the 

column labeled Language.

To edit report labels options:
1  Choose Gradebook Options from the Edit menu and select the Report Labels tab. 

2  Use the Language menu to set the language you wish to customize. Select the last menu item to add your 

own language or to add an alternate set of labels.

3  Edit any of the labels. The built-in label will be used unless you enter your own.

Gradebook Options: Palm Setup
EGP Clipboard, the Palm OS companion to Easy Grade Pro, can be used to record student scores, atten-

dance and notes on a Palm OS handheld. EGP Clipboard 4.0 is required; older versions of EGP Clipboard 

will not work with Easy Grade Pro 4.0. For information on obtaining EGP Clipboard 4.0, please view 

www.easygradepro.com.
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A Class Without Students
Whenever you view a class that has no students, a window will appear (shown below) requesting that you 

choose how students are to be added to the class. 

Whenever possible, click the Copy Students from the PRIOR TERM button because the students will appear 

without any more effort on your part and will be identical in both classes. The Copy Students from an-

other Class button should be your second choice. This is explained in the section Copying Students to other 

Classes on page 41. If you have access to another Easy Grade Pro gradebook or a text file with the students, 

you can click the Import from another file button. Importing students is explained in Chapter 16, Porting. 

Only select the Type Student Names button if it is your only option. This is explained next. 

Adding Students to a Class by Typing
1  Open the Records window to the first empty student record. There are four ways to do this: 1) click the 

Type Student Names button (shown above); 2) choose Add Student from the Tool menu; 3) click the large 

Add Student button found in the charts; or 4) click the Add Student tool   on the tool bar.

2  Type the Last name and press tab. Type the First name and press tab. Notice that after both names are 

typed, the Next Student >> button that leads to the next record becomes highlighted. Any highlighted but-
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ton can be selected by pressing the enter key. After the names have been entered, you can move to the next 

student by pressing this key. Be careful: if you press enter intending to move down to the next field in this 

record, you will actually move to the next student’s record. If this happens, click the << button.

3  (Optional) Enter the ID and press tab. The small button to the right of the ID number field opens a 

window where automatic ID numbers can be set.

4  (Optional) Set the student’s gender. Gender is used in filters that show and hide certain students and in 

clipboard text when Easy Grade Pro must choose the proper pronoun when generating text.

5  (Optional) Edit the student’s status. You may choose between Active, WD (grayed) and WD (hidden). 

WD is an abbreviation for withdrawn.

6  (Optional) Edit the student’s grade scale. Grade scales can be set up in the Class Options window.

7  (Optional) Edit the student’s report language. This option affects the titles and labels used in progress 

and missing work reports. Report labels can be edited in the Gradebook Options window.

8  (Optional) Edit the Custom Labels and Custom Data fields. There are twelve custom data fields. You can 

set the labels of these fields as well as enter any kind of information. You might include phone number, 

parent name, address (to be used in mailing labels), reading group, etc.

9  (Optional) Enter a Website Password. The password is used to gain access to Easy Grade Pro’s HTML 

Multi- and Single-class Website reports. It is not used with any other internet reports. Additionally, the 

password is used as a filter when creating these reports: only students with passwords will have reports cre-

ated. The case of the password is not important but it must consists of numbers and letters only. No spaces 

are allowed. It must be at least six but no more than twenty-four characters in length. The small button to 

the right of the Website Password field opens a window where automatic passwords can be set.

10  (Optional) Enter Email Address #1 and Email Address #2. These are used when emailing reports to 

students, parents or guardians. If all or most of your students have the same domain ( i.e. @orbissoft.com 

), then you may omit it. A default domain can be set up in the Email/Internet window that will get used for 

any student with an incomplete email address in these fields.

11  Press enter or click Next Student to move to the next student or click Done.
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Copying Students to other Classes
If you teach the same students in more than one section or subject, be sure to use the Copy Class Data tool 

to copy your students from one class to others. You can copy students with some or all of their data. If the 

student with a matching ID already exists in a class being copied to, the student will not be duplicated but 

the data about the student will be copied anyway. Use this tool to copy students to other subjects, to update 

student record information and to transfer a student from one section to another.

To copy students from one class to others:
1  Choose Copy->Students from the Tool menu or click the Copy Class Data tool   and select the 

Students tab. 

2  In the upper-left list, select the class to copy from. 

3  In the lower-left list, select the classes to copy to. Be sure that you don’t select the class that is selected in 

the upper list. To select multiple items, hold down the shift, ctrl (Windows) or command (Macintosh) key 

while clicking.

4  Select the students you wish to copy in the list on the right. 

5  Check all of your settings to ensure that you are copying the right students to the right classes. 

6  Click the Copy button. A window will open allowing you to select the specific student data to be copied. 

Select all desired data and click the Copy button.
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Managing your Students
You can change the names or other data in student records. You can change order, delete, withdraw and 

transfer your students. This section explains how to perform these basic tasks.

To change a student’s name or other record data: 
1  Open the record by double-clicking on the student’s name in any chart except the seating chart.

2  Edit the name or other data. Click Done.

3  Repeat these steps for each class in which the student data should be changed.

To change the order of your students, do one of the following: 
•  Press on a student’s name in the score, attendance or student chart and drag up or down. 

•  Choose Sort Students from the View menu. You can sort in a variety of ways.

•  Click the Sort tool  abc   to sort by name. In the seating chart this tool sorts randomly.

To delete a single student: 
1  Click on the student’s row number (to the left of the name) in one of the charts. 

2  Click the Delete tool    or press the delete key.

3  Repeat these steps for each class in which the student is to be deleted.

To delete multiple students: 
1  Choose Delete Student from the Tool menu. 

2  Select the students in the list. Click the Delete button. 

3  Repeat these steps for each class in which the student are to be deleted.

To withdraw a student: 
1  Open the student’s record by double-clicking on the student’s name in one of the charts.

2  Use the Status menu to select either WD (grayed) or WD (hidden) and click Done. If you choose WD 

(grayed), the student will remain visible in the charts but will appear grayed and the data will not be edit-

able. The letters WD are appended to the name of the withdrawn student. If you choose WD (hidden), the 

student will be removed from all charts but will remain in the Records window.

3  Repeat these steps for each class in which the student is to be withdrawn.

FAQ: How do I reshow a student once the status has been set to WD (hidden)?
To show a student whose status has been set to WD (hidden), choose Records from the Chart menu and select the 
Students tab. Use the Record pop up menu in the right corner to switch to the student’s record. Use the Status menu to 
change the status to Active or WD (grayed).

To transfer a student when classes match: 
If the two classes match exactly (assignment order, assignment settings, calendar settings, score footnotes, 

etc.), it is easy to transfer a student using the Copy Class Data window.  Refer to the section titled Copying 

Students to other Classes on page 41 for help with this. You could also use basic copy and paste as follows:

1  Select the student’s row number (to the left of the name) in one of the charts.

2  Choose Copy from the Edit menu. 

3  Switch to the class the student is transferring to. If this class is in another gradebook, be sure you don’t 

quit Easy Grade Pro. Rather, choose Close from the File menu and then open the other gradebook.

4  Select the row number where you want to insert the student.

5  Choose Paste from the Edit menu. 
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To transfer a student when classes do not match: 
Transferring a student is more difficult when the classes don’t match. If possible, print out scores and at-

tendance charts and retype the data into the proper columns. If this is not be possible, you may want to 

add a new assignment column used solely to give the student a transfer grade. Use an assignment name 

like Tommy’s Transfer Grade. Set the assignment’s maximum score to 100. Set the assignment’s points val-

ue to the sum of all the points currently in the class. This will ensure that the student’s transfer grade has 

the same weight as all the assignments currently in the class. Set the assignment’s progress report option to 

Include if student has score. In the score cell for this student, enter the transfer percent. If you use category 

weighting in the class, you may need to follow these steps for each of the categories. 

Adding Assignments
Assignments can be added to a class by typing, by copying from another class or by importing from a class 

in another gradebook. This section explains how to add assignments by typing. 

1  Open the Records window to the first empty assignment record. There are three ways to do this: 1) select 

Add Assignment from the Tool menu, 2) click the large Add Assignment button in the score or assignment 

charts or 3) click the Add Assignment tool  .

2  Type the assignment Name and press tab.

3  Type the assignment’s Maximum Score and press tab. Type the assignment’s Points. Ignore these fields if 

the assignment is being used for extra credit or is a nongraded item. For a thorough discussion of Maxi-

mum Score and Points, be sure to take a look at the FAQs on the next page.

4  Select the assignment’s due date. The calendar is initially set to the current date. If the date showing is 

not the current date, the computer’s clock may be improperly set or its clock battery may be dead.

5  Select the assignment’s category. The category is used in summaries, reports and in grading (if categories 

are weighted). To edit categories, choose Class Options from the Edit menu and select the Category tab. 

FAQ: Why are the dates wrong on the calendars and in the charts?
This problem indicates that the computer’s clock is not set properly or the clock’s battery is dead. Use the computer’s 

Date and Time control panel to set the clock. Refer to your computer’s manual for help in replacing a dead battery.
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FAQ: What are maximum score and points? How should I set them?

By definition, an assignment’s maximum score is the score that is worth 100%. It’s the score that is given when 

everything is correct (ignoring extra credit). Perhaps you like to score papers using percents (scores between 0 and 

100). In this case, as a percents-grader, you should keep the maximum score at 100. Perhaps you count the number 

of problems the student has correct to get the score. In this case, as a problems-grader, you should set the maximum 

score to the total number of problems. Perhaps you apply differing amounts of points to problems based on difficulty 

and then sum the points the student has earned to get the score. In this case, as a points-grader, you should set the 

maximum score to the number of points possible on the assignment.

Easy Grade Pro uses the maximum score to do one thing only: calculate a student’s percent on the assignment. If a 

student’s score is 15 and the maximum score is 20, Easy Grade Pro calculates (15/20) x 100 and gets 75%. Notice that 

the maximum score has nothing to do with the value of an assignment. A student can have a 15 out of 20 on a small 

assignment as well as on a huge semester project. How is one assignment given more value than another? It is done 

through the use of assignment points! 

By definition, an assignment’s points is the number of points to be earned when a student’s score is equal to the 

maximum score. Using the example above in which the student’s score is 15 out of 20, the student will get 75% of 

whatever value is set for points. The student will receive 15 points if there are 20 points possible, 75 points if there are 

100 points possible, 150 if there are 200 points possible and so on. 

So, how should you set an assignment’s points? The answer depends on your grading style. If you are a points-grader, 

you should use the same number for maximum score and points. When you do this, the student’s score, whatever it 

is, will be equal to the number of points earned. If you are a percents-grader or a problems-grader, simply keep the 

points set at 100 for a typical assignment, 200 for an assignment worth double, 50 for an assignment worth half and 

so on. Be sure to see FAQ: How is a student’s overall grade calculated? on page 51.

FAQ: If I use category weighting, does it matter how I set assignment points?
If you use category weighting (i.e. Quiz 30%, Homework 50%, Final Exam 20%) and you want all assignments in a 
category to have the same value, simply set points on all of them to 100, or to 10 or to anything -- as long as they are 
all the same. However, if you want one assignment to be worth more than another assignment in the same category, 

then follow the guidelines in the prior FAQ.

6  Select the Special Status option. Special status options include the following:

•  Normal. No special action is taken. 

•  Extra credit. Any score entered for a student will increase the number of points the student has earned 

without increasing the number of points possible. In other words, the student’s average will go up. Stu-

dents without scores are unaffected.  

•  Can be dropped. Easy Grade Pro will drop this assignment for a student if, by dropping it, the student’s 

overall percent is improved more than by dropping any other assignment that can be dropped. A letter d 

is drawn next to a dropped score. Easy Grade Pro will drop the single, most-damaging score for a student 

among assignments whose status is Can be dropped unless you have set dropping options in the Class Op-

tions window. 

•  Not for grade. The assignment will not be included when determining grades. It can be used for record-

ing items such as whether a progress report has been returned. It can also be used to temporarily turn off a 

group of assignments so that they do not influence the overall grades.

•  (-) Negative Points. A score entered for a student will decrease the number of points the student has 
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earned without decreasing the number of points possible, causing the average to go down. Students with-

out scores are unaffected. 

FAQ: Why can’t I change the status on one of my assignments? It is stuck on Normal.
If you have set up an Extra Credit category in the Class Options window for a class, then all assignments in that 
category will automatically have their status set to Normal. This can’t be changed because it makes no sense to have a 
droppable, extra credit or non-graded extra credit assignment. For more information on Extra Credit categories, refer 
to the section Class Options: Score Category on page 25.

7  Select the Display Scores option. Use this to set whether the scores will appear as scores, percents or 

grades in the score chart. A pop up menu in the score chart (see page 59) can override this setting.

8  Select the Progress Report option. Progress report options include the following items:

•  Include Assignment. The assignment will be included on every progress report whether the student has a 

score or not.

•  Include if Student has Score. The assignment will be included only if the student has a score. This option 

allows you to add columns to your score chart that only apply to one or some students. It also allows you 

to enter assignments in advance and prevent them from appearing too soon in progress reports.

•  Exclude Assignment. The assignment will not be included in any progress report. 

9  (Optional) Select one or more standards from the Standards menu. If there are standards in this class, 

you can link up to ten of them to an assignment. By linking a standard, you will be able to enter rubric 

scores on this standard in the Standard chart.

10  (Optional) Enter text in the Note field. Text could include the assignment objective or purpose. It can 

also be used in conjunction with custom filters to allow you to show or hide the assignment based on any 

criteria that you choose.

11  Select Next Assignment >> to move to the next assignment or select Done.

Copying Assignments to other Classes
If you teach more than one section of a subject, be sure to use the Copy Class Data tool to copy your as-

signments from one class to others. This can save you lots of time and help ensure that your assignments 

are consistent across classes.

To copy assignments from one class to others:
1  Choose Copy->Assignments from the Tool menu or click the Copy Class Data tool    and select the 

Assign. tab. 

2  In the upper-left list, select the class to copy from. 

3  In the lower-left list, select the class(es) to copy to. Be sure that you don’t select the class that is selected 

in the upper list. To select multiple items, hold down the shift, ctrl (Windows) or command (Macintosh) 

key while clicking.

4  Select the assignments you wish to copy in the list on the right. Use the blue arrow button to select or 

deselect all list items.
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5  Check all of your settings to ensure that you are copying the right assignments to the right classes. 

6  Click the Copy button.

Managing your Assignments
You can change the name or other data in an assignment’s record. You can change the order or delete your 

assignments. This section explains how to perform these basic tasks.

To change an assignment’s name or other record data: 
1  Open the assignment’s record by double-clicking on the assignment’s name in the score or assignment 

chart.

2  Edit the name or other data. Click Done.

To change the order of your assignments, do one of the following: 
•  Press on an assignment’s name in the score or assignment chart and drag to the new location. 

•  Choose Sort Assignments from the View menu. You can sort by name, date, and category.

To delete a single assignment: 
1  In the score chart, click the assignment’s column number. 

2  Click the Delete tool    or press the delete key.

To delete multiple assignments: 
1  Choose Delete Assignment from the Tool menu. 

2  Select the assignments to be deleted in the list. Click the Delete button. 
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The posting and manipulation of student scores and notes can be tedious and time-consuming. This chap-

ter explains Easy Grade Pro’s numerous tools to make the tasks both fast and easy. 

 

Entering Scores
This section describes a variety of ways to enter scores.

To enter scores by typing:
1  Select the score cell.

2  Enter any number from zero through 999.9.

3  Press enter, return or one of the arrow keys.

To repeat a score:
1  Select the score cell other than the first cell in a column.

2  Press the ‘=’ key.

To delete one or more scores:
1  Select the scores. To select multiple scores, press on the first and drag to the last.

2  Press the delete key.

To move a group of scores:
Use these steps if you have entered a group of scores into the wrong cells, perhaps offset by a single row or 

column.

1  Select the first score cell in the group and drag to the last.

2  Choose Cut from the Edit menu.

3  Select the first cell where the scores should go.

4  Choose Paste from the Edit menu.

To enter a special score (i.e. mi ) using its shortcut (i.e. m):
1  Make sure that the typing mode is set to Allow typing of Special Score Shortcuts. This can be set using the 
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typing mode menu on the tool bar (see the illustration below) or in the General view of the Gradebook 

Options window.

2  Select a score cell.

3  Type the shortcut key. Do not press enter or return; Easy Grade Pro will automatically advance to the 

next cell.

� �

Use the grade click menu (A) to show or hide the row of grades and special scores. Use the typing mode menu (B) to switch between 
typing shortcuts and typing of grades and special scores. 

To enter special scores and grades by typing:
1  Make sure that the typing mode is set to Allow typing of Grades and Special Scores. This can be set using 

the typing mode menu on the tool bar (see the illustration above) or in the General view of the Gradebook 

Options window.

2  Select a score cell.

3  Type the full text of the grade or special score. 

4  Press enter or return. 

To enter special scores and grades by grade-clicking:
1  Make sure that the row of grades is visible on the tool bar (see the illustration above). 

2  Select one or more score cells. To select multiple cells, press on the first and drag to the last.

3  Click on the grade or special score on the tool bar. 

For additional information on working with grades and special scores, see Class Options: Grade Scale on 

page 23, FAQ: What is grade-clicking? How does it work? on page 24, Class Options: Special Score on page 

26, and To display scores as raw scores, percents or grades on page 56.

To fill down a score:
To fill down means to copy a score from a starting cell downwards to the last row. It is typically used when 

most of the scores on an assignment are the same. If there are a few scores that are different, they can be 

changed after filling down. 

1  Select a score cell.

2  If the cell is blank, type the score but do not press enter. 

3  Select the Fill Down tool  F   or choose Fill Down from the Tool menu.

To fill across a score:
To fill across means to copy a grade from a starting cell across to the last column. It is normally used on 

a transferring student to apply the transfer grade to all assignments given prior to the transfer. Note that 

the grade, not the score, is filled across. Each assignment may have a different score but each will have the 

same grade value. An assignment whose special status is Not for grade is ignored during filling across.

1  Select a score cell.

2  If the cell is blank, type the score but do not press enter. 

3  Select the Fill Across tool  F   or choose Fill Across from the Tool menu. If this tool is not visible, 

press on any tool or empty tool location and hold the mouse down for at least a second. From the menu 
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that pops up, choose the tool.

To enter scores directly from student papers:
By using Easy Grade Pro’s Find tool, it is easy to enter scores directly from student papers -- even if the 

papers consist of an unsorted mixture of assignments, classes and students. Here’s how:

1  Open the Find window by clicking the Find tool    or by choosing Find from the Tool menu.

2  Choose by Name from the Search menu and select Use Continuous Search Mode. By selecting the con-

tinuous search mode, Easy Grade Pro will reopen this window after each score is entered.

3  (Optional) If the stack of papers includes several classes, select Search all current-term classes. If this is 

selected, Easy Grade Pro will search other classes if the student cannot be found in the current class. If you 

have the same student in multiple classes, you may wish to search using some other search field that you’ve 

set up for this purpose.

4  Click Exit. The window will close. You are now ready to begin entering scores.

5  Select the score cell for the first paper. Enter the score and press enter. The Find window will reopen.

6  Enter a few letters of the name from the next paper. Easy Grade Pro will attempt to complete the stu-

dent’s name for you.

7  Click Find or press enter. Easy Grade Pro will find the student and select the score cell in the same col-

umn as before. If the wrong student is selected, edit the search text and click the Find Again tool  , 

choose Find Again from the Tool menu or simply press enter twice to find to the next match. If the select-

ed cell is in the wrong assignment column, use the arrow key to switch columns.

8  When you are done, deselect Continuous Search Mode and click Exit. The window will close.

FAQ: Why does the Find window keep popping up when I enter a score?
This window will reappear whenever a score is entered if the Use Continuous Search mode is turned on. This mode 
allows you to quickly enter scores directly from student papers. The next time the Find window opens, turn this op-

tion off.

FAQ: How does Easy Grade Pro treat blank score cells? How can I easily set all blanks to a certain score?
In Easy Grade Pro, a blank score has no value and is completely ignored when calculations are made. This allows 
you to add assignments in advance without affecting calculations. It also allows you to add assignments that are not 
meant for all students. If you set an assignment’s Progress Report option to Include if Student has Score, the assign-
ment won’t even appear in a report until the student has a score. The Show Blanks filter can be used from the View 
menu to hide all scores except those that are blank. Don’t think that you’ll have to spend a lot of time filling in all 
the blanks with zeros; the Change Scores tool  ?  ?   can easily change all blanks (or just some blanks) to zeros (or 

something else) with just a few clicks. (See the next section.)
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To convert blank cells to a certain score:
Using the Change Scores tool  ?  ? , you can change scores of one type, such as blank, to another score, 

such as mi. You can choose to change scores on all assignments, displayed assignments or just selected 

ones.

1  (Optional) If you want to change scores on some, but not all assignments, select the assignments (by 

pressing on the column number and dragging left or right) or use a filter in the View menu to show just 

certain assignments.

2  Select the Change Scores tool  or choose Change Scores from the Tool menu. If this tool is not visible, 

press on any tool or empty tool location and hold the mouse down for at least a second. From the menu 

that pops up choose the tool.

3  Use the first menu to select the score to change. If you select Text Score--> from the menu, be sure to 

type a numeric score.

4  Use the second menu to select the new score. As before, if you select the last item in the menu, be sure to 

type a numeric score.

5  Select the range of assignments to be included. If you choose All displayed assignments, any assignments 

hidden by filters will not be affected. Choose Selected assignments ONLY if you selected at least one assign-

ment column before opening the window. 

6  (Optional) If you would like ungraded assignments to be included, select the Include “Not for Grade” 

item. The “Not for Grade” attribute is set in the record window for an assignment.

7  Click the Change button.

Adding Footnotes and Notes to Scores
A footnote is a short, numbered, predefined note that can be quickly added to one or more scores. It is 

used to provide additional meaning about the score. Footnotes can be viewed and edited in the Class Op-

tions window, Footnote view.

In the score, seat and standard charts, a footnote appears as a small number between one and nine in the 

lower-left corner of the score cell. However, in a progress report, the full text of the footnote appears with 

the score.



51CHAPTER 6: Using the Score Chart

FAQ: How is a student’s overall grade calculated?
Understanding the math behind the calculations of a student’s overall grade can help you use Easy Grade Pro more 
effectively. It can also help you explain a student’s grades when asked by an inquisitive parent or student. Two ex-
amples will be used to explain the process and both use the following five sample assignments: 

Let’s take a close look at this chart. The student is being graded on two quizzes, two homework assignments and one 
homework assignment with status set to extra credit. On Quiz 1, the teacher set maximum score to 10 and points to 
100. The student’s score is 6.5. Easy Grade Pro first calculates percent: (6.5/10)x100 = 65%. It then calculates points 
earned: 65% of 100 points possible = 65. Take a moment to examine the numbers for the other assignments.

Example 1: When Category Weighting is Off
When category weighting is off, Easy Grade Pro calculates an overall grade by summing the points earned and divid-
ing by the total points possible. Here’s how it does it:
1. Sum the points earned (last column): 65 + 80 + 50 + 37.5 + 2 = 234.5
2. Sum the points possible (Points column): 100 + 100 + 50 + 50 = 300
3. Divide points earned by points possible to get the overall percent: 234.5/300 = 78.17%

Example 2: When Category Weighting is On
In this example, the Quiz category is weighted 30% and Homework is weighted 50%. A third category, Final Exam, is 
weighted 20% but is not yet being used. When category weighting is used, Easy Grade Pro goes through the calcu-
lations in Example 1 for each category. Then it combines the categories using the category weights to calculate the 
overall percent. It works properly even though not all categories are being used.
 Quiz Homework
1. Sum the points earned (last column):  65 + 80  = 145 50 + 37.5 + 2 = 89.5
2. Sum the points possible:  100 + 100 = 200 50 + 50 = 100
3. Divide to get the category percent:  145/200 = 72.5% 89.5/100 = 89.5%
4. Combine the categories percents using their weights to get the 
 overall percent: ((72.5% x 30%) + (89.5% x 50%)) / (30%+50%) = 83.125%

How an Extra Credit category affects calculations
With Easy Grade Pro, you can add extra credit by increasing a student’s score, by setting the status of an assignment 
to Extra Credit (illustrated above) and by creating an Extra Credit category in the Class Options window. 

When using an extra credit category that is not weighted, Easy Grade Pro will use the assignment’s Maximum Score 
and Points to calculate the points earned by the student on the extra credit. Then it will follow the steps in Example 1 
but ignoring the Points possible on the extra credit assignment in step 2.

When using an extra credit category that is weighted, Easy Grade Pro will follow steps 1 through 3 in Example 2 
above to calculate the student’s extra credit category percent.  But in step 4, it will exclude the extra credit category 
when summing the category weights  (the part to the right of the division symbol). 

For a related topic, see FAQ: How can I check the calculations for one of my students? on page 89.
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A footnote number appears in the lower-left corner of a score cell (A) but the full text appears with the score in a progress report (B).

To attach a footnote to a score, do one of the following:
•  Right-click (Windows) or control-click (Macintosh) on the cell and select the footnote from a contextual 

menu that pops up. To delete a footnote, choose the first item in the menu.

•  Double-click the score to open the Score Note window and select a footnote. To delete a footnote, select 

the first list item.

•  Select one or more score cells and click on a footnote in the Mini-summary palette. If the palette is not 

visible, choose Show Mini-sum. in the Gradebook Options window, under the General tab. Press on the 

menu on the palette to display the list of footnotes. Select the first list item to delete a footnote.

The Mini-summary window can be used to attach footnotes to scores.

In addition to score footnotes, you may attach unique and lengthy notes to scores. You may even use notes 

instead of scores for special situations. The section that follows explains how to attach notes to scores.

To attach a note to a score:
1  Double-click on a student’s score cell or select the score cell and click the Open Score Note tool . 

The Score Note window will open.

The Score Note window allows you to attach a unique, lengthy note to a score. The sample Score Cell in the upper-left corner shows 
how the note alters the appearance of the score cell.

2  Use the Format menu to select one of the following: 

•  Note is for teacher; footnote is for student. The footnote but not the note will appear in a student’s prog-

ress report. 

•  Note is for student. The note will appear in a student report. A footnote is not allowed. 

•  Note is for student in place of score. The note will appear in a student report in place of a score. A footnote 
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is not allowed. 

3  Type the note or use the Clipboard tool to paste in a note created in the Clipboard Text view of the 
Gradebook Options window. See Gradebook Options: Clipboard Text on page 37 for additional information 

on Clipboard text. 

The sample Score Cell in the upper-left corner shows how the note alters the appearance of the score cell. 

If you add a note using the first or second formats, a small, black box appears in the upper-right corner of 

the cell. A footnote number may appear in the lower-left corner. If you choose the third format, a picture 

of a notebook covers the score cell indicating that a score is not allowed.

4  (Optional) To check the spelling of the note, click the Spell button.

5  (Optional) To add a note for a different student or assignment, use the menus and buttons at the top 

and bottom. 

6  Click Done. 

Adjusting Grades: Dropping, Extra Credit, Curving and Locking
You can raise and lower student grades by dropping scores, adding extra credit, curving assignments and 

curving /locking overall grades. This section explains how to perform these tasks.

To drop the most damaging scores for each student:
1  Choose Assignment from the Chart menu.

2  In the Status column, choose Can be Dropped for one or more assignments. Only assignments with this 

setting will be eligible for dropping.

3  Choose Score from the Chart menu. 

Easy Grade Pro will regrade each student and drop the score that results in the greatest improvement in 

the student’s overall grade. If you would like to drop more than one score, then complete the next step as 

well:

4  (Optional) To have Easy Grade Pro drop more than one score, choose Class Options from the Edit 

menu and select the Category tab. In the Dropping/Extra Credit column, select the number of scores to be 

dropped in each category. There is a limit of four. For more information on this, refer to the section Class 

Options: Score Category on page 25.

When a score is dropped, a small letter d is drawn in the upper-left corner of the score cell. As new scores 

are entered, the d may move about, disappear and reappear.

FAQ: Why wasn’t the lowest score dropped? Why are fewer scores being dropped for some students?
First of all, Easy Grade Pro only drops scores on assignments with status of Can be Dropped. Choose Assignment from 
the Chart menu and look in the Status column to check for this.  Next, it drops only one score for a student unless 
Dropping options have been set in the Class Options window. In this case, up to four scores can be dropped. Choose 
Class Options from the Edit menu and select the Category tab to check for this. Finally, Easy Grade Pro does not 
drop the lowest scores. Rather, it drops the most damaging scores. These are the scores that, when dropped, result in 
the greatest improvement in the student’s overall percent. For a student who has her lowest score on an assignment 
with little point value or in a category with little weight, Easy Grade Pro may drop a higher score. For a student who 
performs well on tests but poorly on homework, the student’s lowest test score may actually be helping to prop up his 
overall percent; in this case Easy Grade may not drop any test. In all cases, Easy Grade Pro will drop scores or not 
drop scores to maximize the benefit to the student.
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To add extra credit, do one of the following:
•  Increase the score on any normal assignment.

•  Add a new assignment and set its status to Extra Credit. With this method, the assignment does not have 

a maximum score or points value. Scores that are entered for students are treated as points and are added 

directly to the students’ points-earned totals. Be careful to enter scores that are proportional to the number 

of points possible in the class or else the effect of the extra credit may be too little or too great.

•  Add a new assignment and set its category to Extra Credit. This option is only available if you’ve set up 

an extra credit category in the Class Options window. With this method, the assignment does have a maxi-

mum score and points value. If you are not using category weighting, be careful to set the points value 

in proportion to the number of points possible in the class. When you enter a score, Easy Grade Pro will 

calculate the student’s points earned and add them to the total points earned.

To view how extra credit is affecting a student’s grade, see FAQ: How can I check the calculations for one of 

my students? on page 89.

To curve an assignment:
In Easy Grade Pro, curving an assignment means to change student scores in a methodical way to produce 

a better distribution of grades.  Some assessments result in distributions of scores are too wide or too low. 

Curving can help produce the desired distribution in cases like these. Here’s how:

1  Select the assignment by clicking on its title in the score chart.

2  Choose Curve Assign. from the Tool menu or select the Curve tool . The Summaries window will 

open to the Assignment Grades view where you can optionally view a list of students ranked by scores, a 

graph of student performance as well as a curve pane (bottom). 

3  In the Options pane on the left, turn on the Show Curve Pane item and click the disclosure button to its 

left to reveal the curve options (shown below).
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To the right, you will see a curve graph. Here are some things to notice about the graph:

•  Along the bottom axis are numbers that represent possible range of scores on the assignment. The colors 

indicate each grade.

•  Above this axis are boxes -- one for each student. These are also color coded to indicate the grade. 

•  There is a vertical line for each grade in the grade scale. At the top of the line is the grade label. Below 

each grade is a number that represents the cutoff score for that grade. 

4  To change the distribution of grades, do the following:

•  Click the Shift Curve <<Left button to cause the vertical lines to move to the left one step.

•  Click the Shift Curve Right>> button to cause the vertical lines to move to the right one step.

•  Press on a vertical grade line in the graph and drag it left or right. Note: a line cannot be moved onto or 

past another grade line.

5  To view the exact score that a student will receive based on your changes, click on a column of boxes.

6  To curve the assignment, click the CURVE NOW button. Warning: Easy Grade Pro will replace the stu-

dents’ original scores with the new scores. The assignment’s title will change to reflect that this assignment 

has been curved. If  you do not want to lose your original score, first duplicate the assignment before curv-

ing.

FAQ: How can I keep my original scores on an assignment that I want to curve?
When an assignment is curved, the original student scores are replaced by curved scores. If you’d like to keep the 
original scores but not have them impact student grades then try this: 1) Choose Assignment from the Chart menu. 2) 
Press on the assignment’s row number to select it. 2) Choose Copy from the Edit menu. 3) Choose Paste from the edit 
menu while the column is still selected. It will become duplicated. 4) In the status column, change the status of the 
original assignment to Not for Grade. Optional: change the Progress Report option to Exclude Assignment. Be sure to 
curve the duplicated assignment instead of the original.

To lock or curve the overall grade:
1  Choose Lock/Curve Grade from the Tool menu.  The Summaries window will open to the Class Grades 

view (shown below). 
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2 In the Options pane on the left, set the View menu to Overall. Turn on the Show Chart item.

3  To lock a grade, press on the small circle under the column with the lock icon. From the menu that pops 

up, choose Next higher grade, Next lower grade or Other (if you would like to type in your own percent). 

The new percent will appear in the list and a lock icon will appear in the lock column. Typically, lock-

ing a grade is something that is only done at the end of a term because, once a grade is locked, it does not 

change even when scores are added.

4  To curve a grade, press on the small circle under the column with the lock icon. From the menu that 

pops up, choose one of the Curve items or Other (if you would like to type in your own percent).  If you 

type a new percent, be sure to put a ‘+’ or a ‘-’ in front of the offset percent (i.e. ‘+5.0’ or ‘-5.0’). The new 

percent will appear in the list and a curve icon will appear in the lock column. Curving a grade can be 

done at any time. The student’s grade is adjusted by the offset amount every time a score is entered.

To unlock a grade or to remove a curve offset, press on the lock or curve icon and, from the menu that ap-

pears, choose Unlocked value. 

5  Click Done. A small +/- symbol is drawn in the score chart for a student with a curved grade. A small 

padlock is drawn for a locked grade.

A small +/- symbol is drawn for a student with a curved grade. A small padlock is drawn for a locked grade. Click on these symbols to 
open the Summary window where overall grades can be edited.

Customizing the Display of your Data
You can customize the display of data in the score chart in a variety of ways. This section explains how to 

customize the score chart to meet your unique and changing needs.

To display scores as raw scores, percents or grades:
An assignment’s display of scores can be set in its record window. To override this setting so that the scores 

on all assignments are displayed as raw scores, percents or grades, use the small menu next to the intersec-

tion of the first student row and the first assignment column shown below.

�
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Press on this menu (A) to set the display of scores to raw scores, percents or grades.

To resize the assignment title region:
If your assignments’ titles are long, you can give them more room in the score chart. If the titles are con-

sistently short, you can take away some space so that more student rows can be shown on your screen. To 

resize the column height, press and drag the thick, horizontal line below the assignment titles up or down. 

�

To resize the column height, press on the thick line below the assignment titles (A) and drag up or down.

To add a column to display points earned, term grades, attendance totals, special student record information, 
class rank, etc.:
1  Press on the column title above the column of student names (or an adjacent column) and, from the 

menu that pops up, choose Add NEW Column. A new column with student names will appear. Note: this 

menu item will become disabled if the eight-column limit has been reached.

2  Press on the new column’s title to bring up the menu again, but, this time, choose the desired content for 

the column. 

3  To resize the column, press on the vertical line to the right of the title and drag left or right.

4  To move the column to a new location, press on any data beneath the column’s title and drag left or 

right. Note: this does not work with the column of student names. To move this column, drag the other 

columns around it.

5  To delete a column, press on the column title an choose Delete THIS Column.

� � �

To add a column or to change its content, press on the column’s title (A). 
To resize a column, press on the vertical line to the right of the title (B) 



58 CHAPTER 6: Using the Score Chart

and drag. To move a column, press on a data cell and drag.

To show just one student or a subset of students: 
•  To show only a single student, choose the student from the pop up menu immediately above the first 

row number in the score chart. This enters the show one mode in which the vertical scroll bar scrolls the 

students one at a time drawing each in the first row. The Find tool allows you to find any student and still 

never have more than one student visible. 

• To show or hide selected students, press on a student’s row number. Drag up or down to select multiple 

rows. Then choose Show Selected or Hide Selected from the View menu. 

•  Choose Show All from the View menu to return to the normal view. 

To show just one assignment or a subset of assignments:
•  To show a single assignment, choose the assignment from the pop up menu to the left of the first assign-

ment’s column number.

•  To show assignments in a single category, choose the category from the pop up menu to the left of the 

first assignment’s column number. 

• To show or hide selected assignments, press on an assignment’s column number. Drag left or right to 

select multiple columns. Then choose Show Selected or Hide Selected from the View menu. 

•  Choose Show All from the View menu to return to the normal view. 

To show missing work, failing students, blank scores, absent students, the top 10, improvers, decliners or other 
special groups:
Choose one of the custom filters from the View menu or from the pop up menu immediately above the 

vertical scroll bar. For information on editing and creating custom filters, see  Gradebook Options: Filters 

on page 35.

Auto-filling Attendance Scores
You can have Easy Grade Pro enter scores into your score chart based on attendance codes that you’ve en-

tered in the attendance chart. For example, if you’ve entered an attendance code of AE (excused absence) 

for three students on a day when one or more assignments are due, you can have Easy Grade Pro enter 

scores of ab on those assignments for those three students. 

To set up scores for auto-filling:
1  Choose Class Options from the Edit menu and select the Attendance tab.

2  Under the Auto-fill Score column, select the special scores to be used for auto-filling. Scores can be cre-

ated under the Score tab in the same window.

To auto-fill attendance scores:
1  Choose Score from the Chart menu.

2  Select the column or columns that you would like to auto-fill by pressing on an assignment’s column 

number and dragging left or right. You can select any assignments regardless of date because Easy Grade 

Pro will only fill in scores when the date of the assignment matches the date of the attendance code.

3  From the Tool menu, choose Score Tools-> Auto-fill Attendance Scores or click on the Auto-fill At-

tendance Scores tool 1 . If this tool is not on the tool bar, press on hold on any unused tool (or on an 

empty tool location) and, from the menu that pops up, choose this tool.  
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Using the 
Standard Chart7

This chapter explains how to use Easy Grade Pro’s standard chart for standards-based grading. It first 

presents the rationale for standards-based grading and then explains how to set up and manage rubrics 

and standards. Finally, it describes the two views of the standard chart: how and when to use each to enter 

standard scores. Since the standard chart has much in common with the score chart (i.e. how scores and 

notes are entered and how to customize the display of data), be sure to refer to Chapter 6, Using the Score 

Chart to become familiar with the features common to both. To view the standard chart, choose Standard 

from the Chart menu.

Traditional Grading vs. Standards-based Grading
Since standards-based grading is new relative to traditional grading, it may be helpful to compare the two 

grading methodologies. Traditional grading is easy to spot because it typically involves:

•  Simple letter grades.

•  Assessments based on teacher-defined criteria.

•  A single overall grade per student based on a combination of related and unrelated assessments of skills, 

knowledge, performance and conduct over a period of time. 

The main advantages of this method are simplicity and professional freedom. However, it results in a very 

limited measure of a student’s abilities. The A on a child’s report card might thrill the parents, but this 

grade obviously doesn’t convey any precise information. Standards-based grading overcomes this problem. 

The essential qualities of standards-based grading involve:

•  Rubrics with meaningful labels.

•  Assessments based on specific state, district or school-wide standards.

•  Multiple grades per student: one for each standard that reflects the student’s ability related to the stan-

dard at a certain moment in time.

 

Obviously, this more complete assessment comes at a significant cost: it takes more time. Easy Grade Pro 

offers tools to help minimize the amount of extra time needed and tools to take advantage of all the new 

information. 
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Rubrics
Before standards-based grading can occur, a class must have one or more rubric scales. Each class in an 

Easy Grade Pro gradebook automatically comes with a set of rubrics but you can edit these and add your 

own to better match your standards. A rubric consists of labels like Exceeds Standard, Meets Standard, Ap-

proaching Standard and Below Standard and numeric values like 4.00, 3.00, 2.00 and 1.00. 

To edit rubric options:
1  Choose Class Options from the Edit menu and select the Rubric tab.

2  To set the rounding level for all rubrics to whole numbers, tenths or hundredths place, use the menu 

below the left list.

3  To view or edit a rubric, click on its row number. The labels and values will appear in the list to the right 

where they can be edited. 

4  To create a new rubric, click the small blue button above the left list and choose the appropriate item 

from the menu that appears. Type the name of the rubric in the list on the left and then type the labels and 

values in the list to the right. The values must be in descending order. Use the small blue arrows to insert 

or delete a row anywhere in a rubric. 

5  (Optional) Easy Grade Pro automatically calculates the minimum value needed for each item in a rubric 

scale. To edit these minimums, click on the small blue button above the right-most scroll bar. A window 

will open where editing can occur. 

6  To duplicate or delete a rubric, first click on its row number. Then click the small blue button above the 

left list and choose the appropriate item from the menu that appears.

7  The first rubric item in the list is the most important one because it is initially assigned to all standards. 

In addition, it is automatically used for the overall, or combined, standard grade. To move a rubric to the 

top position, press on its row number and drag it upwards.

To copy rubrics from one class to others: See Copying Class Options to other Classes on page 31.

To set the display mode of rubrics: See Gradebook Options: General on page 32.
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Standards
Before standards-based grading can occur, standards must be added to a class.  What is a standard? In Easy 

Grade Pro, a standard consists of an ID, level, text, rubric, grading method, and weight. Here is a partial list 

of standards for middle school science showing these attributes:

ID Level Standard Text Rubric Grading Weight

SCI 1 STANDARD SYSTEMS: THE STUDENT KNOWS AND APPLIES 
SCIENTIFIC CONCEPTS AND PRINCIPLES TO UNDER-
STAND THE PROPERTIES, ...

4-POINT AVG. OF 
STRANDS

1.00

SCI 1.1 Strand Properties: Understand how properties are used to 
identify, describe, and categorize substances, materials, 
and objects...

4-POINT Avg. of Indicators 1.00

SCI 1.1.1 Indicator Understand how to use physical and chemical properties... 4-POINT Power law 1.00

SCI 1.1.2 Understand the positions, relative speeds, and changes ... 4-POINT Power law 1.00

SCI 1.1.3 Understand sound waves, water waves, and light waves... 4-POINT Power law 1.00

SCI 1.2 Strand Structures: Understand how components, structures, 
organizations, and interconnections describe systems.

4-POINT Avg. of Indicators 1.00

SCI 1.2.1 Indicator Analyze how the parts of a system interconnect/ influence each 
other...

4-POINT Power law 1.00

SCI 1.2.2 Understand how various factors affect energy transfers... 4-POINT Power law 1.00

SCI 1.2.3 Understand that all matter is made of particles called atoms... 4-POINT Power law 1.00

SCI 1.3 Strand Changes: Understand how interactions within and 
among systems cause changes in matter and energy.

4-POINT Avg. of Indicators 1.00

SCI 1.3.1 Indicators Understand factors that affect the strength and direction of 
forces.

4-POINT Power law 1.00

SCI 1.3.2 Understand how forces can change the motion of objects. 4-POINT Power law 1.00

SCI 1.3.3 Understand that matter is conserved in physical/chemical 
changes.

4-POINT Power law 1.00

SCI 2 STANDARD INQUIRY: THE STUDENT KNOWS AND APPLIES THE 
SKILLS, PROCESSES, AND NATURE OF SCIENTIFIC 
INQUIRY.

4-POINT Avg. of Indica-
tors

1.00

SCI 2.1 Strand Investigating Systems: Develop the knowledge and 
skills necessary to do scientific inquiry.

4-POINT Avg. of Indicators 1.00

SCI 2.1.1 Indicator Understand how to generate a question that can be answered... 4-POINT Power law 1.00

SCI 2.1.2 Understand how to plan and conduct scientific investigations. 4-POINT Power law 1.00

SCI 2.1.3 Apply understanding of how to construct a scientific... 4-POINT Power law 1.00

SCI 2.2 Strand Nature of Science: Understand the nature of scientific 
inquiry.

4-POINT Avg. of Indicators 1.00

SCI 2.2.1 Indicator Apply curiosity, honesty, skepticism, and openness when... 4-POINT Power law 1.00

SCI 2.2.2 Understand that scientific theories explain facts using infer. logic. 4-POINT Power law 1.00

SCI 2.2.3 Analyze inconsistent results from scientific investigations to... 4-POINT Power law 1.00

Standard Attributes:
•  The standard ID uniquely identifies a standard just as a student ID is unique to each student. 

•  It is common for lists of standards produced by educational agencies to display standards in a hierar-

chical list. In Easy Grade Pro, the standard’s Level indicates its position in the hierarchy.  In the list above, 

there are three levels: Standard, Strand and Indicator.  You may have all standards at the same level if 

desired. If you use levels, be aware that student scores can only be entered on standards at the bottom level. 

Easy Grade Pro will then use these scores to calculate the grades for the higher-level standards.

•  The Standard Text is the description of the standard. 
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•  The Rubric is the set of labels to be used to display a student’s performance on the standard. Each stan-

dard can have its own rubric.

•  Grading options include averaging, power law and manual. Standards that have standards linked to them 

from below are always automatically graded based on the average of linked standards. 

•  The Weight can be used to make some standards worth more than others for calculations.

FAQ: How many standards should I add to my class?
It is typical for the lists of standards produced by educational agencies to have literally dozens of standards for a single 
curriculum area at a single grade level. Although, Easy Grade Pro has been designed to accommodate these long lists, 
we recommend that you actually report on no more than a dozen standards. Otherwise, the effort and time required 
may become overwhelming. Students and parents may become overwhelmed as well. Notice the emphasis on the word 
report. It is possible to have standards in a class that are used for scoring but not for reporting. For example, if you 
have 36 standards with six at a highest level, each with six linked, lower-level standards, you can use the 30 lower-
level standards for scoring but the six higher-level standards for reporting. You may end up with only a few scores 
on each of the 30 lower-level standards but these can produce very meaningful data on the six standards that get 
reported. You decide!

Adding Standards to a Class by Typing
Each class in Easy Grade Pro can have up to 128 standards. Standards can be added to a class by typing, 

copying from another class, importing from another gradebook or through the use of plug-in files. This 

section explains how to add standards by typing. 

1  Choose Add Standard from the Tool menu. The Records window will open to the first empty record.

2  Type the Standard ID and press tab. Standard IDs must be unique and can be up to 11 keystrokes in 

length. If your standards are at multiple levels, it’s recommended that you use a dot notation like that 

shown in the list in the prior section to clearly indicate each standard’s position within the list.

3  Choose the standard’s Level from the Level menu. If your standards are all at the same level, choose the 

topmost level for each. If you choose level 2 (i.e. Strand) or level 3 (i.e. Indicator), then you’ll also need to 

choose the link standard – the higher-level standard that this standard belongs to. To edit the label, text 
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style and background color for each level, choose Edit Level Options from the menu. 

4  Type the standard’s text. It can be up to about 200 keystrokes long. 

5  (Optional) Type additional text regarding the standard in the Note field.

6  Select the Progress Report option. Progress report options include the following items:

•  Include Standard. The standard will be included on every progress report.

•  Include if Student has Grade. The standard will be included only if the student has a grade. This option 

allows you to prevent standards from appearing in progress reports unless actually used.

•  Exclude Standard. The standard will not be included in any progress report. 

7  Select the Rubric to be used for converting a student’s numeric grade to a label.

8  Select the grading option from the Grade menu. When making your choice, be sure to consider that a 

student’s standard grade is meant to reflect performance at a certain moment in time rather than perfor-

mance over an extended period of time. Your choices are:

•  Average of scores. Averaging has less usefulness with standards-based grading. However, it can be appro-

priate for very broad standards.

•  Power Law Formula. The power law is an excellent tool when used appropriately. For more information, 

read the section FAQ: What is the Power Law Formula for standards-based grading? 

•  None. This option is best if you want the most accurate grades -- ones that reflect your understanding 

of all the details involved in sets of scores -- and if you have the time! With this option, you would then 

manually enter standard grades in the Summaries window as you analyze graphs of performance.

•  Avg. of linked standards. This option is automatically selected for any standard that has standards linked 

to it.

9  Press Enter or click Next Standard >> to move to the next standard or click Done.

Managing Standards
You can distribute standards via plug-in files, copy standards from class to class, sort them and delete 

them. This section explains how to perform these tasks. 

To use plug-in files to distribute standards to other teachers:
Once a set of standards has been entered into a class, it can be saved as a plug-in file for distribution to 

other teachers. To create the plug-in file, choose Records from the Chart menu, click the Standards tab, 

press on the small blue arrow next to the Standard ID field and choose Save Standards as Plug-in from 

the menu that appears. It is recommended that you name the file using a subject-grade format (i.e. Math 

Grade 5, Reading Grade 6, etc.). Plug-in files can be distributed to other computers and should be placed 

in the Plug-ins folder found in the same folder as the Easy Grade Pro application. To import the standards 

from a plug-in file into a class, choose Records from the Chart menu, click the Standards tab, press on the 

small blue arrow next to the Standard ID field and choose the desired set from the menu that appears. It 

is possible to import standards from multiple plug-in files into a single class; Easy Grade Pro will filter out 

any standards with IDs already present in the class.
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FAQ: What is the Power Law Formula for standards-based grading?
An internet search for “Power Law Formula” results in hundreds of listings in a wide variety of fields including as-
tronomy, meteorology, and engineering. In his highly regarded book TRANSFORMING CLASSROOM GRADING, 
Robert J. Marzano describes the use of this formula for standards-based grading. The math behind the power law 
formula is quite complex (see below), but all that’s necessary for its use is that you know what it does, how to interpret 
its scores, and when best to use it.

In essence, the power law formula predicts what the student’s next score will be based on scores already present. It can 
be thought of as a mathematical calculation that answers the question: “If the student were assessed right now on a 
skill, at what level would the student likely perform?” Since a student’s grade on a standard is meant to be an indica-
tion of skill at a certain moment in time, the power law formula can be used to calculate standard grades.

To gain an understanding of how the power law works, let’s look at sets of student scores and Easy Grade Pro’s power 
law calculation of each set. To keep things simple, let’s say there are four assessments and four students and each 
student has earned the same scores 1.00, 2.00, 3.00 and 4.00, but in a different order.  If we were to simply average 
the four scores, all students would receive a 2.50. However, with the power law, we’ll get different values because the 
power law puts more weight on recent assessments. Let’s take a look:

Assessment 
#1
(least 
weight)

Assessment 
#2

Assessment 
#3

Assessment 
#4
(greatest 
weight)

Power Law 
Score

Interpretation of the Power Law Score

Student
#1

1.00 2.00 3.00 4.00 4.00 The scores show continuous improve-
ment. The student will likely demonstrate 
mastery on the next assessment.

Student
#2

1.00 3.00 2.00 4.00 3.66 The scores show irregular improvement. 
The student will likely demonstrate high 
but not complete mastery on the next 
assessment.

Student
#3

2.00 4.00 1.00 3.00 2.16 The scores show very uneven perfor-
mance. The student will likely demon-
strate a mid-level of achievement on the 
next assessment. 

Student
#4

4.00 3.00 2.00 1.00 1.28 The scores show continuous decline. The 
student will likely demonstrate a low level 
of achievement on the next assessment.

As you can see, the power law formula can result in more meaningful values than averaging. Should it then always 
be used? No! The power law formula is best used on narrowly defined standards (i.e. Subtraction of mixed numbers 
with borrowing). Avoid its use with broadly written standards that consist of multiple skills – the results will be less 
meaningful.

For those with the inclination, here’s the power law formula used by Easy Grade Pro where x is the ordinal number of 

the score, s is the score and N is the number of scores with all scores in date order:

power law score = e

∑(ln x)(ln s)
(∑ln x)( ∑ln s)

N
-

∑( ln x) 2 (∑ln x) 2

N

-

( ∑ln x) + ∑(ln y) (∑ln x)-

N

∑(ln x)(ln s)
(∑ln x)( ∑ln s)

N
-

∑( ln x) 2 (∑ln x) 2

N

-
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To copy standards from one class to others:
1  Choose Copy->Standards from the Tool menu.

2  In the upper-left list, select the class to copy from. 

3  In the lower-left list, select the class(es) to copy to. Be sure that you don’t select the class that is selected 

in the upper list.

4  Select the standards you wish to copy in the list on the right. Use the blue arrow button to select or de-

select all list items. Hold down the Ctrl (Windows), Command (Macintosh) or shift key to select multiple 

items.

5  Check all of your settings to ensure that you are copying the right standards to the right classes. 

6  Click the Copy button.

To change a standard’s text, grading option or other record data:
Open the standard’s record by double-clicking on the standard’s name in the standard chart. Edit the name 

or other data. Click Done. If you change the level of a standard, Easy Grade Pro will automatically re-sort 

your standards by level.

To change the order of your standards, do one of the following: 
Note: If you have standards at multiple levels, Easy Grade Pro will enforce a level-order to your standards.

•  Press on a standard’s text in the 1-Student view of the Standard’s chart and drag to the new location. 

•  Choose Sort Standards from the View menu.

To delete one or more standards: 
Note: If you have standards at multiple levels, you cannot delete a standard that has standards linked to it 

unless you delete the linked standards as well.

1  Choose Delete->Standard from the Tool menu.

2  Select the standards you wish to delete from the list. Use the blue arrow button to select or deselect all 

list items. Hold down the Ctrl (Windows), Command (Macintosh) or shift key to select multiple items.

3  Click the Delete button.

The Two Views of the Standard Chart: 1-Assignment and 1-Student
The Standard chart actually consists of two separate charts: 1-Assignment and 1-Student. You’ll find tabs 

for these below the tool bar. Both the 1-Assignment and 1-Student views can be used to enter scores and 

notes on your assignments and standards. So why are there two charts? Because there are four types of 

data – students, assignments, standards and scores -- it is impossible to show all the data in a two-dimen-

sional view. With the 1-Assignment chart, you can view scores for all students on a single assignment (with 

linked standards). With the 1-Student view, you can view scores on all assignments (with linked standards) 

for one student.

To view or switch between the two standard charts:
1  Choose Standard from the Chart menu.

2  Find the standard tool bar below the main tool bar. Press on the 1-Assign. and 1-Student tabs to switch 

between the two charts. 
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To choose an assignment or student for viewing:
•  Press on the menu immediately below the tabs (B). 

•  Click on the Prior Item    or Next Item tool    (C). 

�

�
� �

To link 1 or more standards to an assignment:
•  In the 1-Assignment chart, press on the Standards tool 1.

2.
(D). From the menu that appears, select 

up to ten standards. Note: only standards that do not have standards linked to them from below can be 

selected and scored.

•  Standards can also be linked to an assignment in the assignments record. To view a record, double-click 

on the assignment’s name or choose Record from the Chart menu. From the Standards menu, select up to 

ten standards.

Traditional versus Standard Scores
In the standard chart, two types of scores can be entered: traditional and standard. Traditional scores are 

the percents-based scores that virtually all grading programs have been designed to handle:  8/10 = 80% 

B-.  Standard scores are scores that correlate to the levels in a rubric: 2.00 = Meets Standard. In standards-

based grading, traditional scores are not required. However, they can be used in beneficial ways. For 

example:

•  Traditional scores can be used in exactly the same way as they are used in non-standards-based grad-

ing. In other words, a teacher can continue to grade based on traditional grading methods and simply add 

standards-based grading to the process.

•  Traditional grades can be used to record completion only. For example, a teacher may use the special 

scores yes, no, mi, ab, inc, etc. to keep track of whether assignments have been completed or not. With this  

method, missing work reports can still be generated.

•  Traditional scores can be used to keep track of an effort grade using a typical A, B, C grade scale or some 

other scale. Although an effort standard could easily be set up, using traditional grading for effort allows 

effort and performance on skill-based standards to be graded separately.

Entering traditional scores:
In the 1-Assignment chart, traditional scores can be entered into the column with the assignment’s name. 

In the 1-Student chart, traditional scores can be entered into the first row below all of the assignment 

names. Since scores can be entered using the same techniques described in the Chapter 6, Using the Score 

Chart, that information will not be duplicated here. 

Please refer to the Quick Reference pages that follow for concise information about using the Standard 

chart.
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Using the 
Other Charts8

Although the score and standard charts are the most comprehensive of the six charts, the attendance, 

seating, student and assignment charts share many of its tools and offer a variety of new ones to help you 

manage your student data. This chapter describes the unique features of these charts. Be sure to refer to 

Chapter 6, Using the Score Chart for explanations of tools shared by the charts. To view any chart, use the 

items in the Chart menu.

The Attendance Chart
The attendance chart allows you to record attendance data for a single term.
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To use the attendance chart:
•  Attendance and calendar options must be set before using the attendance chart. Color options may also 

be set for your attendance categories. Refer to Chapter 4, Setting Options for help with this.

•  Each column of the chart represents a single date in the calendar for the class. Column numbers indicate 

the day numbers into the term. No-school days are grayed and cannot be selected. 

•  To filter the dates displayed in the chart, use the menu to the left of the first column number. You can 

choose between showing all days, the current day, current week, current month or a selected range of 

dates. If the current day, week or month is selected, the actual dates will automatically change at the right 

times.

•  To quickly hide all dates but one, click on the date. When only one date is visible, use the horizontal 

scroll bar to scroll through all dates while keeping only a single date visible at a time. To return to the nor-

mal view, click the date again.

•  To resize the space for the date titles, press and drag the thick, horizontal line below the titles up or 

down.

•  Be sure to display the attendance codes on the tool bar. This lets you know what marks can be typed and 

allows you to enter marks by clicking. To display these codes, press on the small triangle to the left of the 

class menu

Click on the triangle (circled above) to show the row of attendance marks..

•  To add a note to an attendance mark, double-click on a cell to open the student note view of the Sum-

maries window. You may find it helpful to press on the Clipboard tool in this window and choose • Atten-

dance Note ([Date: MO/DY/YEAR]). This text will be pasted into the text field with the actual date.

•  Attendance can be exported over your school’s network. Refer to the section Exporting Attendance on 

page 114 for information on this.

•  To print the attendance chart, choose Print from the File menu. Under the Chart tab, select and print the 

Attendance Chart report.

•  To combine attendance data from multiple terms, refer to Working with Terms starting on page 81.

The Seating Chart
You can set up a seating chart to match your classroom, furniture included. Once set up, attendance marks 

and assignment scores can be entered directly into the seats. 

To set up a seating chart:
•  To set the shape, size, name format and attendance/assignment format of all seats in a class, use the Seat 

options in the Class Options window. Refer to page 30 for help.

•  The first time the seating chart is viewed for a class, Easy Grade Pro places the first 128 students into 
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seats using a built-in arrangement.

•  To move any seat, press and drag it to the desired location. To move a group of seats, first select the seats 

by clicking on each while holding down the shift key or drag a rectangle that encloses or touches the seats. 

To move the group, press on one and drag. To deselect all selected seats, click on any empty place.

•  To swap two students, drag the first seat on top of the other. If one seat is rotated and the other is not, 

be sure to drag the upper-left corner of the first seat to the upper-left corner of the second. Swapping also 

works on groups of seats.

•  To set the color, rotation or locked status of an individual seat, double-click on the seat.  A seat that is 

locked cannot be moved or sorted.

•  To sort your students into the seats, choose Sort Seats from the View menu and select one of the pat-

terns. To randomize your students, click the Sort tool  abc   or choose Randomly from the View menu.

•  To add furniture, choose Add Furniture from the Tool menu or click the Add Furniture tool . If 

this tool is not visible, press on any tool or empty tool location and hold the mouse down for at least a 

second. From the menu that pops up, choose the tool. 

•  To change the size of a piece of furniture, drag the small rectangle in the lower corner. To set the format, 

rotation or name, double-click on the item. The Furniture Options window will open. 

•  Furniture can be copied and pasted using Copy and Paste in the Edit menu. To delete an item, select it 

and click the Delete tool    or press the delete key.

•  The structure of a seating chart and its furniture can be copied to and from other classes. Choose Copy 

Seats from the Tool menu and follow the prompts. When furniture is copied from one class to another, it 

always replaces any furniture that the class may already have.

•  To print the seating chart, choose Print from the File menu. Under the Chart tab, select and print the 

Seating Chart report.

To take attendance using the seating chart:
•  Attendance and calendar options must be set before using the attendance chart. Refer to pages 28 for 

help with setting Attendance options and page 29 for help with setting Calendar options.  In addition, seat 

options must be set to allow the entry of attendance marks. See page 30 for help with this.

•  The current date, if it is within the calendar for the class, will be displayed in the lower-left corner of the 

window. Use the ‘+’ and ‘-’ buttons to switch to other dates. If the date is not the current date, it will be 

displayed in red. 

•  To record attendance, press on the menu in the seat and select a mark, or select one or more seats and 

click on an attendance code on the tool bar. 

•  Attendance can be exported over you school’s network. Refer to the section Exporting Attendance on 

page 114 for information on this.

To enter assignment scores using the seating chart:
• Seat options must be set to allow the entry of assignment scores. See page 30 for  help with this.
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•  To select an assignment for scoring, press on the menu at the bottom of the seating chart. Use the  ‘+’ 

and ‘-’ buttons to switch to other assignments. 

• To enter a score, first click on the score cell in the seat. Enter the score by typing or grade-clicking.

• Use the arrow keys to move to other seats. 

• Use the Continuous Search Mode of the Find tool to instantly jump to the right student. See page 49 for 

help with this.

• To enter a score note, double-click on the score cell. To enter a footnote, right-click (Windows) or ctrl-

click (Macintosh) on the seat.

The Student and Assignment Charts
The student and assignment charts have a lot in common with the Records window: both display virtually 

the same information. While the Records window displays one record at a time, the charts can display all 

records together making them easier to view and manipulate. The charts also offer a variety of tools not 

available in the Records window such as fill down, copy, paste, find and filters.

To use the student and assignment charts:
•  The columns in these charts correspond to the fields in the Records window. 

•  Data can be entered into any cell except in the first column with names. Many of the fields bring up 

menus when selected.

•  To change the order of the columns, press on a column’s title and drag the column left or right to the 

desired location. 

•  To change the width of a column, move the cursor until it is over the vertical line to the right of a col-
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umn title. Press on the line and drag the line to the desired location.

•  To view the record for any row, double-click on the row.

•  To rename any of the twelve custom field columns in the student chart, double-click on the row and edit 

the Custom Labels.

•  As with the score chart, you can use filters, dragging of rows, find, fill down, and cut, copy and paste on 

rows and columns.

•  The last six columns of the student chart can be used to enter comment numbers. Although it is easier to 

enter student comments in the Summaries window, the student chart can be used to view and edit groups 

of comments.



Making and 
Managing Backups9

Why you should have a Backup Plan
Anyone who has used a computer for long knows that computers are susceptible to all sorts of problems: 

software conflicts, corrupted memory, damaged disks, network glitches, hardware breakdowns, user errors 

and more. Problems may be inevitable but their damaging effects can be minimized if one has a good 

backup plan in place and it is followed without exception.

Many computer users maintain only a single backup copy. This is risky behavior! If the backup is stored on 

the same computer as the original, both files could be lost if the hard drive crashes or the computer is sto-

len. Even if the backup is stored apart from the original, there could be problems if the backup was made 

after an undetected problem occurred.

If you have responsibility for reporting student data to others, there will be times during the year in which 

you must have access to your Easy Grade Pro data. Imagine a problem occurring during one of those 

times... if you follow a good backup plan, the solution will be painless.

In the next section, we present a plan for making and managing backups of your gradebook data. You are 

strongly encouraged to follow this plan or some other comprehensive plan for securing your gradebook 

data.

A Two-part Plan for Securing your Student Data
For greatest security it is best to make backups of your student data in different ways and at different loca-

tions. Here is a two-part plan that might work for you:

•  Part 1: Daily Backups. Easy Grade Pro makes this part easy because it can be set up to make automatic 

backups of your gradebook to the volume of your choice using file names that are automatically created 

and that change from day to day to ensure that you have multiple backups. Be sure to see Backup Options

on page 34 for help with setting up Easy Grade Pro’s automatic backup options.

•  Part 2: Bi-Weekly Archived Backups or Printed Reports. Get a box of CD-Rs or other removable media. 

Once a week, save a copy of your gradebook to a disk and store it at a different site. Do not erase a backup 
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until after the school year has ended. Or print score and attendance chart reports for each current class on 

a biweekly basis. Store these away from your archived backups.

How to Make a Backup
We recommend that you take advantage of Easy Grade Pro’s automatic backup options explained on page 

34. You can also make a backup copy of your gradebook manually. Here’s how:

 

1  Choose Save Copy from the File menu or select the Save Copy tool  . 

2  In the window that opens, set the name of the backup. The default backup name is Copy of ‘gradebook 

name’ (on Windows) or ‘gradebook name’ copy (on Macintosh).

3  Set the location for the backup to a folder created for backups or some other location set aside for your 
backups.

4  Click the Save button.

FAQ: My gradebook’s name is ‘Copy of copy of...’. What is going on?
If you have a gradebook with a ‘Copy of copy of...’ in its name, it means you are opening and using your backup 
copies instead of your main gradebook. A backup copy of a gradebook is like an insurance policy -- it’s something 
that you hope you never have to use. Don’t get your gradebook and its backup copies confused, and don’t work on 
a backup of your gradebook unless there is a good reason. For more information on this, see FAQ: Easy Grade Pro 
saves automatically. What does this mean? on page 20.



Working at Home 
and School10

If you would like to use your Easy Grade Pro gradebook on computers at both school and home, this 

chapter is for you. It explains how to transfer your gradebook from one computer to another using a USB 

flash drive, even if the computers are of different platforms (Macintosh and Windows).

Using an Easy Grade Pro gradebook at two locations is similar to using a paper gradebook at two loca-

tions: in both cases, you have to move the gradebook back and forth. There is, however, a fundamental 

difference that can cause problems if you’re not careful. When transferring an Easy Grade Pro gradebook 

using, you’ll be leaving behind a copy so that both computers have identical gradebooks at first. Once you 

make changes to one of the gradebooks, it becomes your current one turning the other into nothing more 

than a recent backup. Be careful to work only with the current gradebook and to transfer it before working 

at a different location. Otherwise, you may find yourself with two gradebooks in which neither is current 

forcing you to retype data into one of them.

You may be tempted to use your gradebook directly from a USB flash drive to avoid this problem. We 

don’t recommend this because flash drives are slower than hard drives. Also, if you accidentally pull out 

the flash drive too early, you risk damaging your gradebook.

 

Getting Started
1  Make sure that you have Easy Grade Pro installed on both computers and that they have the same ver-

sion number (i.e. v4.0). To find the version, choose About Easy Grade Pro from the Easy Grade Pro (Ma-

cintosh) or Help (Windows) menu. 

2  If your gradebook is on a Windows computer, we recommend that you move it to the Desktop or some 

other convenient location so that you’ll have easy access to it. To move it, press on its icon and drag. If you 

don’t know where your gradebook’s icon is, try looking at this path: C:\Program Files\Orbis Software\Easy 

Grade Pro. Its name ends with ‘.egp’.

3  It is important that the gradebook’s name ends with the four characters ‘.egp’.  By default, an Easy Grade 

Pro gradebook will end with this extension even if the extension is not visible.
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Using a USB Flash Drive to Transfer a Gradebook
1  Insert a flash drive it into the USB port of your computer. 

2  Copy the gradebook to the flash disk. Windows:  Right-click on the gradebook’s icon and choose Copy. 

Right-click on the icon of the flash drive and choose Paste. Macintosh: Drag the gradebook’s icon to the 

icon of the flash drive.

3  Eject the flash drive following the instructions for that came with it. Don’t just pull it out or you will 

likely damage the drive or its files. Insert it into the other computer’s USB port. 

4  Copy the gradebook from the flash drive. Windows:  Double-click on the flash drive’s icon to open a 

window to it. Right-click on the gradebook’s icon and choose Copy. Right-click on the folder on the hard 

drive to receive the gradebook or right-click on an empty place on the Desktop and choose Paste. Macin-

tosh: Double-click on the icon of the flash drive. Drag the icon of the gradebook to the folder on the hard 

drive to receive the gradebook. 

5  Eject the flash drive as before. 

6  To start your gradebook, double-click on its icon. This will ensure that you are opening the right grade-

book.

Working Cross-Platform
Easy Grade Pro 4.0 for Macintosh and for Windows can share gradebooks easily and seamlessly. Nearly all 

program features are identical but there are a few platform-specific differences that you should be aware of 

as follows:

•  Different characters are found in fonts. Some characters on the Macintosh, such as the check mark, are 

not available in Windows and vice versa. 

•  Menu item terminology and keyboard keys have some platform-specific differences.

•  Macintosh printers typically allow scaling to enlarge or shrink printed reports. Since fewer Windows 

printers offer this, you will likely need to adjust font size to enlarge or shrink printed reports.



Working with Terms11
If you teach a class that continues with the same students from one term to the next, then this chapter is 

for you. It explains the simple process of starting a new term for an existing class in your gradebook. It also 

explains the more complex process of combining student grades and attendance data from classes in dif-

ferent terms to produce multi-term totals. 

If you need to add a new class to your gradebook -- new meaning a class with new students or new course-

section numbers -- you don’t need this chapter. Instead, take a look at the section To add a class on page 20.

Starting a New Term
Although you can start a new term at any time, we recommend that you wait until the end of a term to do 

so. This will help minimize the number of changes that may need to be made to your roster, seating chart 

and options in the new term.

To start a new term for a class:
1  Switch to the class.

2  From the Tool menu, choose Term Tools->Start New Term. Easy Grade Pro will automatically put a 

check or x for the appropriate term in the Records window for the class. It will then switch to the new term 

and copy the students to it.

3  To set the calendar or edit other class options, click the View/Edit Class Options button in the window 

that automatically appears.

To edit the term label for a term:
1  Choose Records from the Chart menu or click the Records tool  .

2  Select the Classes tab.

3  Edit the name of the term. This change applies to all classes in a gradebook.
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To add the Prior Term  and Next Term tools to the tool bar:
These tools can make it easier to switch back and forth between terms.

1  Press on any tool or empty tool location and hold the mouse down for at least a second. From the menu 

that pops up, choose the Prior Term tool  T .

2  Repeat the process to add the Next Term tool  T .

3  To relocate any tool, press and drag (quickly) the tool to the desired location.

Combining Terms (Class Options: Term)
At any time, you can combine your students’ grade and attendance data from two or more terms to pro-

duce multi-term totals. Once combined, you can view summaries and print reports that include the totals 

and individual term data.

To set or edit term options:
1  Switch to a class in your current term. 

2  Choose Term Tools->Combine Terms from the Tool menu. The Term view of the Class Options window 

will open (shown above).

3  You must decide to combine your term data using weights or points. Select weights if you want each 

term to have a set value. Don’t use this method unless you are at or near the end of the current term 

because temporary grade distortions can occur when the current term has only a few assignments. Select 

points if you want the terms to be combined by summing all the points that a student has earned.  This op-

tion is not available if any of the classes being combined uses category weighting.

4  Choose to match the students across classes by ID or name. Each student’s ID number or name must be 

completely identical in all terms.

5  Carefully select the prior-term classes by pressing on one or more menus below the name of the current 

class. When selecting classes, you must choose between combining the term or the overall grade. In most 

cases, you should choose Term.  However, if one of the classes you are combining has term options set in it, 

you may want to choose Overall instead. 
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Here is an example to explain the difference between Term and Overall. Let’s say your gradebook has five 

terms as follows: Quarter 1, Quarter 2, Quarter 3, Quarter 4 and Year. In the Quarter 2 class, you combine 

Term grades from Quarters 1 and 2. In the Quarter 4 class, you combine Term grades from Quarters 3 and 

4. In the Year class, you could combine Term grades from Quarters 1, 2, 3 and 4 but you could, instead, 

combine Overall grades from Quarters 2 and 4.
 

6  If you have selected Combine grades using weights, enter the term weights in the Weights column. They 

must sum to 100%.

7  Click Done. Easy Grade Pro will go to each of the prior-term classes and try to match the students. 

Whenever a match is found, the student’s points, grade and attendance totals for that term are copied to 

and combined with the current class. A window will appear listing any students that could not be found in 

prior terms.

Questions about Combining Terms
What do I do when a student didn’t match when combining terms but should have?
In most cases, the problem occurs because the student’s name or ID number in the prior-term class is dif-

ferent. Correct this and return to the current class; from the current-term class, choose Term Tools->Re-

combine Terms from the Tool menu. Easy Grade Pro will start the process over and, again, let you know 

who hasn’t matched. 

How often do I need to combine terms? How do I recombine terms?
Generally, you will combine terms only once for a class. However, if you make any changes to grades or 

attendance data in any of the prior term classes, you should recombine the terms to copy the updated 

data into your current term. To recombine the data, choose Term Tools->Recombine Terms from the Tool 

menu.

How do I un-combine terms?
You may occasionally want to combine terms just long enough to print certain reports. To later un-com-

bine terms, choose Term Tools->Combine Terms from the Tools menu. Click the ‘Un-combine’ Terms but-

ton. When you exit from this window, your class will be un-combined.

How is a class changed by using combine term options?
After combining, the Overall grades and attendance totals found in charts, in summaries and in reports re-

flect all combined terms. Many reports and summaries will display multi-term data automatically or as an 

option. In the score and attendance charts, special columns can be added to display data from individual 

terms. (See page 57 for information on adding special data columns.) 



84 CHAPTER 11: Working with Terms

FAQ: I’ve combined terms but the prior-term grades or attendance data in reports are wrong. How do I fix 
this?
This problem occurs if you change grades or attendance marks in a prior-term class after you’ve combined its data 
with your current-term class. To fix this, choose Term Tools->Recombine Terms from the Tool menu. This will copy 
the changed data to your current-term class. 

FAQ: I need to print reports that show grades from multiple terms but I don’t want the grades to be com-
bined to form a multi-term overall grade. What do I do?
Choose Term Tools->Combine Terms from the Tool menu. In the Term view of the Class Options window, combine 
your terms using weights, but set the term weights to 100% for the current term class and 0% for all the prior-term 
classes.

FAQ: I have to include a weighted final exam. What do I do?
When a final exam must be weighted with one or more other terms, the final exam should be treated in the same 
way as the other terms. As an example, you might set up your terms in the Records window as follows: Semester 1, 
Semester 2 and Final Exam. Your Final Exam will actually be a separate class within your gradebook. From within 
the Final Exam Class, you might set the combine term options as follows: Semester 1 - 40%, Semester 2 - 40% and 
Final Exam - 20%. The overall grades will be found in the Final Exam Class.



Using Summaries12
Easy Grade Pro provides two powerful tools for analysis of student performance: the Summaries window 

and the Mini-Summary window. This chapter explains how to utilize both of these tools.

Opening the Summaries Window
The Summaries window can be a tremendous aid in your efforts to identify and meet the needs of your 

students. Its multiple views with graphs, charts, calendars, notes and comments can help you understand 

your students’ strengths, weaknesses and changes in performance over time. The Summaries window also 

is the place to go to curve or lock a student’s overall grade, to lock in a standard grade, to enter notes about 

a class or a student and to enter report card comments.

To open the Summaries window, do one of the following:
•  Select Summaries from the Chart menu. 



86 CHAPTER 12: Using Summaries

•  Click the Summaries tool . To view the summary of a specific student or assignment, select the 

item first and then click this tool.

•  Double-click a row or column number in any chart (except the seating chart).

•  Right-click (Windows) or control-click (Macintosh) on a student or assignment name and choose View 

Summary from the menu that pops up.

Using the Summaries Window
•  Use the Type menu at the top-left corner of the window to choose among the different types of summa-

ries. 

•  Use the Class menu to switch to any class in any term. Since you can freely switch classes, this is very use-

ful when comparing performance across sections of the same course and across terms of the same class.

•  Depending on the type of summary being viewed, the list under the List tab will display students, assign-

ments, standards or classes. Use this list to switch to the desired item.

• A variety of options can be found under the Options tab that allow you to control the display and func-

tion of the summary. 

•  In some of the lists, there are small circles in narrow columns. Pressing on these circles brings up menus 

that allow the locking, curving or unlocking of overall and standard grades. 

•  In some of the lists, there are column titles with small arrows. These indicate that you can click on the 

title and on other titles in the list to sort the column either up or down. The arrow indicates the direction 

of sorting.

Types of Summaries
There are ten different views and each has its own uses as the following chart illustrates.

Summary Type Uses
Assignment 

Grades

View lists of student performance 

on any assignment sorted by 

name or grade.

View statistics.

View bar graphs by grade or stu-

dent with color and other options.

Curve the assignment. See page 

54 for information on using the 

Summaries window to curve an 

assignment.

•

•

•

•
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Summary Type Uses
Class Grades View lists of student performance 

overall or on any category.

View statistics.

View bar graphs by grade or stu-

dent with color and other options.

Lock or curve any student’s over-

all grade. (Pressing on the small 

circles.) See page 55 for informa-

tion on using the Summaries win-

dow to lock or curve a student’s 

overall grade.

•

•

•

•

Class 

Attendance

View lists of students with totals 

on selected attendance categories.

Sort the lists by any attendance 

category.

Get class totals.

•

•

•

Class Notes Record all kinds of notes about 

any class. 

Spell-check. Use clipboard text 

options to insert stored text. See 

Gradebook Options: Clipboard Text 

on page 37 for more information.

•

•

Standard 

Grades

View lists of student performance 

on any standard sorted by rubric 

grade and the number of total 

scores.

View statistics.

View bar graphs by grade or stu-

dent with color and other options.

•

•

•
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Summary Type Uses
Student 

Grades

Views lists of student scores bro-

ken down by term, category and 

assignment.

Lock a student’s overall grade. 

(Press on the small circle.)

View line graphs that show per-

formance over time.

Verify the calculations.

•

•

•

•

Student 

Attendance

View lists of student attendance 

totals broken down by term.

View calendars that display a 

student’s attendance marks by 

date.

•

•

Student Notes Record all kinds of notes about 

any student. 

Spell-check. Use clipboard text 

options to insert stored text with 

variables.

These notes can be included in 

student progress reports that are 

printed, posted online or emailed.

•

•

•

Student 

Comments

Set up a master list of up to 100 

comments. Sort the comments 

and export the list as a plugin file 

to be distributed to others. See Us-

ing Plug-ins on page 118.

Select up to six comments per 

student. 

Use tools to have comments auto-

selected for students based on 

user-defined rules.

Copy comments from the prior 

term.

These comments can be included 

in student progress reports that 

are printed, posted online or 

emailed.

•

•

•

•

•
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Summary Type Uses
Student 

Standards

View lists of student standard 

grades with a variety of options.

Manually lock in a grade for any 

standard or override any calcu-

lated grade. (Press on the small 

circles.)

View graphs of performance on 

any standard with a variety of 

options.

•

•

•

 

FAQ: How can I check the calculations for one of my students?
The Summaries window can help you check all the calculations that go into computing the overall grade for a stu-
dent. To open this window, double-click on the student’s row number and select Student Grades from the Type menu. 
Under the Options tab, turn on the Show Chart option. For a related topic, see FAQ: How is a student’s overall 
grade calculated? on page 51.

Using the Mini-Summaries Window
The Mini-Summary window can display graphs and lists while you are working in any of the charts. It can 

also be used to attach footnotes to scores and show score notes in the score chart. 

To make the Mini-Summary window visible:
1  Choose Gradebook Options from the Edit menu.

2  Select the General tab.

3  Open the Tool Options section.

4  Turn on the Show Mini-Summary option.

Use the small blue button near the top-left corner of the mini-summary window to choose among the dif-

ferent types of summaries. There are six different views as this chart explains:

Summary Type Uses
Class Graph View a class bar graph with class 

average change as percents-based 

and standards-based scores are 

entered.

•
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Summary Type Uses
Assignment Graph View a bar graph with class aver-

age change as percents-based 

and standards-based scores are 

entered.

•

Student Graph View a line/bar graph with stu-

dent performance over time.

Automatically switches between 

percents-based and standards-

based views.

•

•

Student Grades View a list of student totals.•

Score Footnotes Apply score footnotes to one or 

more selected scores by clicking 

on a footnote in the Mini-Sum-

mary.

•

Score Text View the score note for any se-

lected score.

•
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Easy Grade Pro offers numerous comprehensive reports. Regardless of the report, you’ll follow the same 

steps when printing: open the Print Reports window, select the report, set options while viewing a preview 

of the report and then print. This chapter begins by explaining this process in general. It then describes 

each of the reports.

Using the Print Window
1  Choose Print from the File menu or click the Print tool  . The Print Reports window will open

2  Choose a report from the Reports menu near the top. Notice that a preview of the report, based on the 

current set of options, will appear.
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3  To set the range of the reports,  press on the for menu (below the Report menu). You can choose to print 

reports for one class, for all classes in the current term or for selected classes, students or assignments. If 

the choose the last item, then click on the List tab and select one or more items from the list. Depending 

on the report selected, the list will display students, assignments, or classes. To select multiple items, hold 

down the shift, ctrl (Windows) or command (Macintosh) key while clicking.

4  To set the options for the reports, click on the Options tab and make your selections. The report preview 

will be automatically updated as you make your selections.

5  To change the size of the preview, press on the menu below the preview and choose Fit To Window, 

Zoom 1x, Zoom 1.5x or Zoom 2x. The Fit To Window view shows the entire page and the cursor is a magni-

fying glass. By clicking on any part of the page, the view automatically switches to the Zoom 1x view. In any 

of the zoomed views, the cursor appears as a hand. By pressing the mouse button, the page can be dragged 

about. 

6  To change the orientation or paper type for the printed reports, click the Print Setup button in the lower 

left corner.

7  Select Print to begin printing. The Print window for your type of printer will open where you can set 
some final print options and begin printing. 

FAQ: Where is ePrint?
If you are familiar with older versions of Easy Grade Pro, you may be wondering where the ePrint feature is. With 
ePrint, each report page could be saved as a separate file in PICT format (Macintosh) or BMP format (Windows) to 
be opened by virtually any graphics program.  Now that Easy Grade Pro allows you to create HTML reports, ePrint-
ing has much less usefulness and Easy Grade Pro 4.0 no longer officially offers ePrint. However, it still can be found. 
Here’s how: on a Windows computer, hold down the Ctrl (Windows) or option (Macintosh) key while clicking the 
Print button in the lower right corner of the Print window. Be sure to save the reports to an empty folder!

General Options for all Reports
Under the Options tab, you’ll find a list of options for each report. The bottom set of options are titled 

General Options for all Reports. These options are shared by all reports and include:

•  Font Options. Use this to set the font type and size. To maximize the amount of data that will fit on a 
page, set the font size to a small value.

•  School or Teacher name.  This will appear near the top of all reports.

•  Custom Report Title. Use this option to change the name of any report (i.e. Washington School Report 
Card). 

•  Custom Report Date. Use this option to change the date that appears of a report in case you don’t want 
the current date to appear. In fact, you can use this option to include any text, not just the date. 

•  Print in color. Most reports can be printed in color. Keep in mind that color printing typically costs more 
and takes longer.
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FAQ: How can I maximize the columns on each page?
To maximize the number of columns that will fit on a page, use the Page/Print Setup options to set the orientation to 
landscape view (sideways) and the scale to between 60% and 80%. If your printer doesn’t support scaling, set the font 

size to a small value. 

FAQ: How do I print multiple reports per sheet of paper?
Many printers today allow you to choose the number of pages to be printed on each sheet of paper. They do this by 
shrinking each page the correct amount and placing the pages at different locations on the paper. These options are 

known as layout options and can be found in the print window that appears after you click the Print button. 

FAQ: How do I change the teacher or school name that appears on reports?
Site license version: The school’s name is entered into the program when it is first used. It can only be changed by 
reinstalling the program. The teacher’s name can be changed in the Print Reports window. Single-user license ver-
sion: The teacher’s name is entered into the program when it is first used. It can only be changed by reinstalling the 
program. The school’s name can be changed in the Print Reports window. Note: it is safe to reinstall Easy Grade Pro 

without losing any data as long as your gradebook is not named Demo Gradebook or Demo.egp. 

Types of Reports
There are numerous reports and each has its own features as the following chart illustrates.

Report Description
Assignment 

Chart

This report mirrors the onscreen Assignment 

chart. It includes assignment names and their 

record information (i.e. maximum score, 

points, date, category, etc.). 

Options allow you to select the record items 

to be included in the report.

It can be used for archiving assignment 

record settings.

•

•

•

Assignment 

Graphs

This report includes bar graphs of students 

grades on one or more assignments.

A variety of statistics can be included.

It can be used as a poster for classroom dis-

play since student names are not included.

•

•

•
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Report Description
Assignment 

Summary

This report includes ranked lists of students 

and their grades on one or more assign-

ments.

It can be used as a poster for displaying 

grades on an assignment.

•

•

Attendance 

Chart

This report mirrors the onscreen Attendance 

chart. 

It can be used for recording attendance on 

paper, for reporting term attendance to the 

office and for archiving attendance data.

•

•

Attendance 

Summary

This report includes a chart of student at-

tendance totals broken down by category and 

term. 

It can be used for reporting attendance infor-

mation and for analysis.

•

•

Class Graphs This report displays bar graphs of overall 

grades in one or more classes.

It can be used as a poster for classroom dis-

play since student names are not included.

•

•

Class Missing 

Work

This report includes a very concise list of 

missing work in one or more classes. If you 

select multiple classes, the missing work will 

be combined across classes.

The missing work can be grouped by student 

or assignment. 

Although it is meant for the teacher, it can 

be used as a poster or cut up and given to 

students. 

•

•

•
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Report Description
Class Notes This report allows you to print the notes 

in the Class Notes view of the Summaries 

window. 

It can be used for reporting and archiving the 

notes.

•

•

Class Roster This report includes a chart with student 

names and blank columns.  

Columns can be normal width (like the score 

chart) or half-width (like the attendance 

chart). Only the columns needed to fill a 

single page will be included. Column titles 

can be left blank or printed with your titles.

It can be used to hand-enter student data.

•

•

•

Class 

Summary

This report includes a chart of overall, term 

and category grades with points, percents, 

grades and GPA.

It can be used for reporting grade informa-

tion and as a poster.
    

•

•

Labels Use this report to print student record infor-

mation and limited grade information to the 

most popular Avery® labels for laser and ink 

jet printers.

Print mailing, file folder and other labels. 

•

•

Multi-class 

Gradesheet

This report displays overall grades, percents 

or GPAs for multiple classes in a single chart.

Grades can be combined across classes us-

ing the Class Weights found in the Records 

window. 

Elementary teachers can use this report to list 

all subject grades for all students. Secondary 

teachers can use this to produce a ranked list 

of students across classes. 

•

•

•
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Report Description
Score Chart This report mirrors the onscreen Score chart. 

Extra rows and columns can be included. 

It can be used for recording assignments 

and scores on paper, for reporting term at-

tendance to the office or for archiving score 

data.

•

•

•

Seating Chart The seating chart report mirrors the on-

screen Seating chart. 

In can be used for reference, taking paper at-

tendance, for learning student names and for 

substitute teachers.

•

•

Standards 

Chart

This report displays standards, standard 

grades and standard scores for all students.

A variety of statistics can be included.

It can be used for archiving student standard 

data and for analysis of performance on stan-

dards individually and as a class.

•

•

•

Student Chart This report mirrors the onscreen Student 

chart. It includes student names and their 

record information (i.e. ID, gender, status, 

address etc.). 

It can be used for archiving student record 

data and for creating specialty reports for 

book numbers, phone number, addresses, 

etc. 

•

•

Student 

Missing Work

This report includes a list of assignments 

for which a student has scores that count as 

missing. It can include missing work from 

multiple subjects for a student in a single 

report.

Use this to report missing assignments to 

students and parents.

•

•
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Report Description
Student Notes This reports allow you to print the notes in 

the Student Notes view of the Summaries 

window. You can also include the score notes.

It can be used for reporting and archiving 

these notes.

•

•

Student 

Progress (re-

port card)

This report includes comprehensive infor-

mation about a single student from one or 

multiple classes.

Extensive options are available giving you 

great control over the content of each report.

It can be used to report student information 

to parents, students and for student folders. 

It can be used as a report card.

•

•

•

FAQ: How can I get a progress report to fit on a single sheet of paper?
One way to shorten a progress report is to limit the number of assignments that are included. There are two common 
ways to do this: 1) in the options window for a progress report, click the set button after the Assignment Chart option, 
choose Assignments on or after-> from the Include menu and set a date on the calendar; 2) in the score chart, use 
items in the View menu to hide some of the assignments; in the options window for a progress report, click the set but-
ton after the Assignment Chart option and choose Displayed Assignments Only from the Include menu. 

FAQ: Some assignments are not showing up in progress reports. How do I fix this?
From the Chart menu, choose Assignment. Find the column labeled Progress Report. Make sure you don’t have this 
field set to Exclude on assignments to be included. 

FAQ: Why are classes missing on a student’s multi-class progress report? Why am I getting two different 
multi-class progress reports for a student, each with different classes?
The student’s name or ID number is different in the different class(es). Correct the name or ID number and print 
again. 
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FAQ: How do I remove the Overall column in a multi-class progress report?
If you have combined two or more terms, the multi-class progress report automatically includes columns for each 
term and for the overall grade. If you want to include individual term grades but not the overall column, combine 
your terms using weights of 0% for each prior term class and 100% for the current term class. Also, do not curve or 
lock the overall grade for any student in any current term class. Under these conditions, Easy Grade Pro will auto-
matically omit the Overall column.
.

FAQ: How can I use the multi-class progress report as a report card for multiple teachers’ grades?
First create a master gradebook that contains gradebooks from multiple teachers. To do so, start a new gradebook. 
When a window appears stating that the gradebook has no classes, click the Import button (or choose Import from the 
File menu). Under the Built-in Formats tab, select Combine Gradebooks and click Next. In the window that appears, 
select one of the gradebooks and click Open. In a matter of seconds, all classes in the other gradebook will be imported 
in the master gradebook. Continue using the Combine Gradebooks format until all gradebooks have been imported. 
Print reports. It is important that the students’ names or ID numbers are identical in all teachers’ gradebooks. Note: 
there is a 250 class limit for a gradebook which means that you can typically combine up to ten gradebooks.

FAQ: How do I show points in a progress report?
In the options window for a progress report, click the set button after the Grade Summary Chart option and turn on 
Points Earned. Click the set button after the Assignment Chart option and turn on Points Earned.

FAQ: How can I use a progress report as a missing work report? ...as an attendance report?
In the options window for a progress report, turn on the Assignment Chart item, click the set button after this item 
and choose Missing Assignments Only from the Include menu. For an attendance report, turn on the Attendance 
Summary item, click the set button after this item to select the desired attendance items. Click the Labels button in 
the main Print Reports window to change the title of the report.

FAQ: What is the Completed Work Average and how is it calculated?
The Completed Work average, which is found in summaries and reports, is calculated in the same way as the student’s 
Overall average except that assignments with scores that count as missing and scores of zero (which typically indicate 
missing work) are omitted. If a student has no scores that count as missing nor zero scores, then the Overall average 
(assuming that terms have not been combined) and the Completed Work average will be identical. Since missing 
scores and zeros can have a large, negative impact on a student’s Overage average, the Completed Work average can 
be useful in assessing student capabilities and in motivating students to complete work.
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Keeping students and parents regularly informed about classroom performance can be one of the most 

beneficial tasks that a teacher can perform. It can also be time-consuming and costly. By using Easy Grade 

Pro’s emailing tools, this task can become quick and inexpensive. Easy Grade Pro allows you to email stu-

dent progress reports directly to students and parents without any need for a dedicated email program.

In order to email, you’ll need two things: 1) email addresses of students, parents, or guardians, and 2) 

access to an SMTP (email) server that supports the most common protocols for emailing. In many cases, 

you can use the SMTP server that you use for emailing at school or at home.  Unfortunately, the free email 

services likely won’t work; they are typically limited to encourage people to switch to fee-based services. 

Fortunately, there are numerous inexpensive services available. Visit www.easygradepro.com for our cur-

rent recommendations. Although not required, we strongly recommend that you use a high-speed internet 

connection so that the emails can be sent quickly.

Email Addresses
You can enter up to two email addresses for each student in a class for the student, parent, or guardian. If 

a student does not have an email address, the student will be excluded when reports are emailed. If many 

or most students have the same domain (i.e. student1@myserver.com, student2@myserver.com), then you 

can omit the domain (i.e. @myserver.com); a default domain can be entered later for all students with 

missing domains.  

To enter email addresses in the Records window:
1  Choose Records from the Chart menu.

2  Select the Students tab.

3  Select the first (or desired) student from the Record menu.

4  Enter email addresses in the Email Address 1 and Email Address 2 fields.

To enter email addresses in the Student chart:
1  Choose Student from the Chart menu.
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2  Find the columns titled Email 1 and Email 2.

3  Type the addresses.

Email Setup Options
Before you can send emails, you will need to set certain options in your gradebook known as Email Setup 

options. You will need information from your school or your ISP for setting these options. It may be help-

ful to study your Account settings in your current email program – the settings in Easy Grade Pro will 

likely be very similar. 

When setting these options, accuracy is critical; spelling, punctuation, spacing must be exact or else the 

SMTP server will reject the emails.

To set Email Setup options:
1  Choose Email/Internet from the File menu. The Email/Internet window will open (shown above).

2  From the Action menu, select Email Student Reports. 

3  Select the Options tab.

4  Find the Email Setup section and click the button to the left to open the list of options. 

5  In the Teacher Email field, enter your email address. This is used 1) when you send emails to yourself to 

confirm that emails are being sent properly and 2) as the return email address when the recipients want to 

respond to the emails you’ve sent.

6  In the Teacher Name for Email field, enter your name as you’d like it to appear in the From field in the 

receiver’s email program.

7  In the SMTP (email) Server field, enter your outgoing email server name. SMTP servers are the com-
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puters that take the emails we send and route them through the internet. The SMTP server name often 

includes the letters ‘smtp’. 

8  The Override default SMTP port option should not be set unless your documentation directs you to set 

this. If so, turn this option on and set the port number in the box.

9  The next set of options involves Authentication. Authentication is a process in which Easy Grade Pro 

proves your identity to the SMTP server so that it will accept your emails. If your SMTP server requires 

authentication (and most do), turn on the SMTP Server requires authentication option on and enter your 

Account ID and Password. 

Easy Grade Pro supports the most common authentication types. If your SMTP server requires an au-

thentication type not supported by Easy Grade Pro, then it will refuse the connection. In this case, it will 

be necessary to use a different SMTP server. There are many inexpensive SMTP services available on the 

internet that support the most common authentication types. Visit www.easygradepro.com for our current 

recommendations. 

10  The Batch emails to avoid spam-blocking options should not be set unless you experience a certain type 

of problem while emailing. If you are able to regularly email a certain number of reports and then receive 

an error message, you may be experiencing spam-blocking. Some SMTP servers limit the number of 

emails being sent at one time in an attempt to block spam.  Easy Grade Pro will display the error message 

from the SMTP server; it may be cryptic or it may clearly indicate that the SMTP server has stopped ac-

cepting emails because too many have been sent (i.e. 451 requested action aborted: too many messages on 

a single connection). If you suspect spam-blocking, turn on this option and use the Emails in batch option 

to set how many emails are sent as a group and the Delay between batches option to set the delay in seconds 

between each group of emails. Setting the batch to 1 and the delay to 60 seconds will likely be successful 

but may require a lot of time to email all reports. Use a trial-and-error approach to find settings that will 

allow successful emailing in the least amount of time. Alternately, you could switch to a less restrictive 

SMTP server.

11  (Optional) If many or most of your student email address share the same domain and you entered their 

email addresses without domains, put the domain in the Default @domain for incomplete email addresses 

field.

Emailing Reports
Once you have entered email address for your students and have entered Email Setup options, you are 

ready to begin emailing. Here’s how:

1  Choose Email/Internet from the File menu. The Email/Internet window will open.

2  From the Action menu, select Email Student Reports. 

3  From the for menu, choose which students are to receive emails. Students without email addresses will 

be automatically omitted. If you select the Students selected in the list option, then click the List tab and 

select the desired students. Hold down the Ctrl (Windows), Command (Macintosh) or shift key to select 

multiple students. 

4  Select the Options tab. In the Email Subject field, enter the text that you would like to have appear in the 
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receiver’s email program in the Subject field. If you would like to have the student’s name or ID also ap-

pear in the subject, set the with Student menu appropriately.

5  Set the Email To options. At least one item must be selected. It is strongly recommended that, at first, you 

send all emails to yourself exclusively until you are happy with the results. Then send emails to others.

6  Set all desired options in the Report Options section of the list of options. As you make changes, they 

will be reflected in the preview pane to the right.

7  Click the Send button to begin emailing. If this button is disabled, then check your Email Options to 

ensure that you have everything set up properly. Also, make sure that, if you are emailing only to students 

selected in the list, you have at least one student selected.

8  (Optional) Click the Email Log button to open the window where you can view the results of all email 

attempts. This window can be especially helpful if errors occur so you can determine which students were 

sent emails.

FAQ: I’ve emailed reports successfully but some receivers explain that they can’t view them. How come?
Easy Grade Pro’s email reports use HTML to make them more readable, professional-looking and attractive. Most 
email programs will have no trouble displaying them. In some cases, a user might turn off HTML in their email 
programs and so won’t be able to view the report. In other cases, a user might have an email program that is too old 
to display HTML. In anticipation of this, Easy Grade Pro’s report emails include an alternate message to be displayed 
to minimize confusion...

“This student grade report is in HTML format. Since your email program does not understand this format, 
you will not be able to view it. Please inform the sender.” 

If a person reports this to you, advise them to try to turn on HTML in their email program or switch to a newer one.
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Easy Grade Pro offers different ways to securely post student reports on the internet: Website Reports, 

Edline and Basmati. Each is very different and has its own set of features. Use the chart below to help you 

choose the best option for your situation and then jump to the appropriate section that follows for de-

tailed instructions. This chapter also explains how to create HTML student reports for general use.

WEBSITE REPORTS EDLINE BASMATI

Web server School or district web 

server or web space 

provided by an ISP.

Secure server provided 

and maintained by 

Edline.

School or district web 

server.

For Individuals and schools. Schools and districts. Schools and districts.

To upload The teacher uses Easy 

Grade Pro to create a 

folder of reports. The 

teacher then uses an 

ftp program (or other 

means) to upload the 

folder to the web server.

Easy Grade Pro works 

closely with Edline to 

automatically upload 

reports to Edline’s web 

server. 

The teacher uses Easy 

Grade Pro to create a 

report file. The teacher 

then uses a web browser 

to upload the file to the 

web server.

Security Password protection. 

Passwords are managed 

by the teacher.

Encryption of uploaded 

reports. Secure web site. 

Passwords for school 

personnel, students and 

passwords.

Password protection.

Other Free. Can work with ex-

isting school or personal 

web pages. 

Monthly or annual fee. 

Full-featured service. 

Import students into 

Easy Grade Pro from 

Edline.

Free. Can work with ex-

isting school web pages. 
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Using Website Reports
Easy Grade Pro’s Website Reports are for individual teachers and for schools that want a free and secure 

way to post student reports for viewing on the internet. Easy Grade Pro creates the reports and the security 

pages. The reports can then be transferred to your school’s web server or to web space provided by an ISP 

using ftp or some other means.

To gain access to a report, the viewer must enter the student’s name and password. Security comes through 

the use of encrypted student report names and Javascript built into web browsers. For best security, we 

recommend that reports are not viewed using computers shared by others in a public environment be-

cause the browser history stored by web browsers may allow access to reports previously viewed. This risk 

can be substantially reduced if the browser history is turned off.

To set up Website Reports with password security:
1  Choose Student from the Chart menu and enter passwords in the Password column. Not only are pass-

words used to gain access to reports on the internet, they are used as filters when creating reports: students 

without passwords are skipped. Passwords may consist of letters and numbers and must be between six 

and twenty-four characters in length. They are not case sensitive.

FAQ: I’ve imported passwords. Why aren’t they showing up?
It is possible to import student passwords from roster files into Easy Grade Pro gradebooks. However, if the password 
is not at least six characters in length, Easy Grade Pro will discard it. Passwords below this minimum are substan-
tially easier to hack; that’s why Easy Grade Pro won’t accept them.

2  Choose Email/Internet from the File menu or click the Internet tool  @   to open the Email/Internet 

window (shown below).
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3  From the Action menu, select Create Website Reports.

4  From the for menu, select the classes. If you only teach one class or if you wish to post only one class on-

line, then select the first item. Most teachers will select the second item to include all classes in the current 

term. If you select the last item, be sure to select one or more classes from the list below the List tab.

5  Set options under the Options tab. The effects of most options are instantly viewable in the preview to 

the right. The Security Page Options are exceptions. The security page is a password page where the viewer 

must choose a class, enter a name and password. Use the Include Greeting Text option to create a message 

for this page. Use the Include Teacher Email to enter your email address if you’d like it to appear as well.

FAQ: How can I ensure that I don’t compromise the privacy rights of my students?
For the greatest security, we recommend that you either turn off the Include Student Title Data option or that you set 
the Student Identifiers option to Omit for Security. This will help ensure that, even if a report is hacked, the identity 
of the student will remain unknown.  

6  Click the Create button. Follow the prompt to create a folder on your desktop. Give the folder an exact 

name such as ‘teacher name’ Grades. Perhaps your school will provide you with a name. Easy Grade Pro 

will automatically create the main page, named index.html, other special files and a folder with reports for 

each class. Be sure to use the same folder name every time you create reports so that the link that you set 

up to your index.html does not break when uploading new reports.

FAQ: Why don’t I see an index.html page in each folder?
When creating Website reports, Easy Grade Pro will remind you to name the main file as index.html. However, Easy 
Grade Pro does not force you to use index.html in case your school wants you to use something else. If you changed 
this name either by accident or on purpose, then Easy Grade Pro will remember this name and reuse it the next time. 
To change it back, go through the steps to create website reports and change the name back to index.html. 

7  Quit Easy Grade Pro.

8  (Optional) To view the reports before uploading them to your web server, find the folder you created 

with the reports, open it and double-click on the index.html page. If it doesn’t open, first open your web 

browser, choose Open from the File menu, then navigate to the index.html page and open it.

9  Transfer the folder of reports to your web server.  If you will be posting grades on your school server, 

your school may provide you with the instructions to complete this step. If you will be posting grades on 

your ISP’s web server, then you will likely need an ftp program to upload the folder. FTP programs are 

commonly available at computer software stores. Your ISP will be able to provide you with the settings that 

you’ll need for your ftp program. If your web layout program includes an ftp program, you may be able to 

use it to upload the folder of reports to your web server. 

10  Using a web layout program, provide a link from you school’s web page or a personal web page to the 

index.html page within your folder of grade reports on your web server. The web layout program will have 

instructions on how to set up links.
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Using Edline
Edline provides a complete Internet platform that serves as your school’s website or as a companion web-

site. It allows easy uploading of student reports directly from Easy Grade Pro making it the easiest way to 

regularly upload reports. For information view www.edline.com or call 1-800-491-0010. Once your Edline 

account has been set up and your school’s classes and students have been defined, you’ll be able to begin 

downloading classes and uploading student reports.

To download classes and students:
1  Create a new gradebook but do not add classes to it. For help with this step, refer to the section Starting 

a New Gradebook on page 19. You do not need to add classes yet.

2  When the Guide Me: No Classes window appears, click the Edline Class Data Sync button. Or, choose 

Email/Internet from the File menu.

3  From the Action menu, choose Sync Classes with Edline and click the Sync button. Follow the prompts 

that appear. To update your class rosters at a later date, choose Email/Internet from the File menu and 

repeat this step.

To prepare your classes for uploading reports:
If you downloaded classes and students from Edline using the Sync Classes with Edline tool, then your 

gradebook is already set up for uploading reports. Otherwise, you will need to enter ClassIDs for all classes 

and IDs for all students before uploading. Here’s how:

1  Obtain lists of ClassIDs and student IDs from your school.

2  To enter ClassIDs, choose Records from the Chart menu and select the Classes tab. Find the Custom 

Data title. Enter the ClassID into the first row under Custom Data unless you are directed by your school 

to use a different row. Switch to the next class and repeat this. Continue until all classes have ClassIDs.

3  To enter student IDs, choose Student from the Chart menu. Find the ID column and enter all student 

IDs. Continue until all students have IDs in all classes.

To upload reports:
1  Choose Email/Internet from the File menu or click the Internet tool  @   to open the Email/Internet 

window.

2  From the Action menu, select Upload Reports to Edline.

3  From the for menu, select the classes. If you select the last item, be sure to select one or more classes 

from the list below the List tab.

4  Select the Options tab and set the Edline Options:

•  The Edline Report/Folder Name is the name of the folder to hold the reports on Edline. This name will be 

visible to viewers. You can use one or more folders for different reports such as Quarter 1 Reports, Quarter 

2 Reports, Final Reports, Missing Work Reports, November Grades, etc. If you want to upload reports that 

replace older reports for your student, use the same name for the folder. If you want to upload reports that 

do not replace older reports, use a new folder name.

•  From the Get Edline ClassID from menu, select the field in the Records window that is holding the Clas-
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sID. Select the first item unless your school directs you to select something else.

5  If you turn on the Include Multiple Classes (in each report) option, then you will need to enter a special 

ClassID into the Edline (multi-class) ClassID field. Don’t do this unless your school directs you to do so 

and provides you with a special ClassID. You must also enter an Edline (multi-class) Class Title (i.e. Ms. 

Demo’s 6th Grade).

6  Set the remaining report options under the Options tab as desired.  

7  Click the Upload button. If you are not using an always on connection to the internet, be sure to con-

nect before clicking Upload. Easy Grade Pro will open your web browser to the Edline server and send the 

reports. During the process you will be prompted to enter your Edline screen name and password. 

8  View one or more reports. To view the reports, log into Edline and go to the home page for any class 

whose reports you uploaded. Click on the name of the report folder in the Contents box. You will see a list 

of reports. The title of each report is the student’s name. To view an individual report, click on a student’s 

name. You, as the teacher, will see all the reports. When students and parents click on the folder, they will 

only see their own reports.

Using Basmati
Basmati is open-source software which means the software is not only free, but the actual code is available 

and can be freely modified by those that know how. It can run on your school or district’s web server. 

Software and documentation are available for downloading at http://www.sourceforge.net. (Search for 

Basmati.) Parents and students can use a single password to view grades from all classes and teachers. 

Once your school or district has set up the software on its server, you can use Easy Grade Pro to generate a 

single grade file with information on all of your students and classes and upload it to the server using your 

browser. 

To prepare your classes for uploading reports:
1  Ensure that each class in your gradebook has a Course Code and other values. These codes may be 

imported into your gradebook directly from school administration software or you may need to manu-

ally enter them into fields in the Records window for each class you teach. To open this window, choose 

Records from the Chart menu. Then select the Classes tab. Typically, the Course Code will be in the first 

field under the Custom Data title and the others below it. Follow the instructions provided by your school.

2  Ensure that each student has a student ID. The IDs may be imported into your gradebook directly from 

school administration software or you may need to manually enter them. The student ID can be entered 

into the student ID field in the Records window, under the Students tab or can be entered directly into the 

Student chart. Choose Student from the Chart menu to view this chart.

To create a Basmati report file:
1  Choose Email/Internet from the File menu or click the Internet tool  @   to open the Email/Internet 

window.

2  From the Action menu, select Create Basmati file.

3  From the for menu, select the classes. If you select the last item, be sure to select one or more classes 

from the list below the List tab.
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4  Select the Options tab and set the Basmati Options using these guidelines:

•  Course#. Set this to the appropriate custom field in the Records window. This field is required.

•  Section# and Period#. Set these to omit or to the appropriate custom fields in the Records window.

•  Students and Assignments. Use these to set which students and assignments are to be included. Use these 

in conjunction with the filters found in the View menu.

•  Teacher Name. Put your name in this field.

•  Teacher Email. Put your email in this field. This field is required.

•  Tchr ID. Put your password in this field for access to Basmati. This field is required.

•  Phone. Put your school phone number in this field.

•  Control. Leave this field blank unless instructed to use it.

5  Click Create and save the Basmati.txt file to the desktop of your computer or some other location.

6  Quit Easy Grade Pro.

To upload a Basmati report file to your school’s web server:
1  Open your web browser and navigate to your school’s Basmati Faculty page. 

2  Log in and click the Submit File button. 

3  Click the Browse button. Find and select the Basmati.txt file you created with Easy Grade Pro. 

4  Click the Submit File to Basmati button. 

5  For security, be sure to delete the Basmati.txt file when done uploading.

Creating HTML Reports
You can create student reports in HTML format for viewing on your own computer. These can be useful 

when conferencing with others about student performance.

To create student HTML reports:
1  Choose Email/Internet from the File menu or use the Internet tool  @   to open the Email/Internet 

window.

2  From the Action menu, select Create HTML Reports.

3  From the for menu, select the students. If you select the last item, be sure to select one or more students 

from the list below the List tab.

4  Set options under the Options tab. 

5  Click the Create button. Follow the prompts to create a folder on your desktop. You may wish to name it 

something like Student Reports. Easy Grade Pro will create a folder inside it with student reports for each 

class.

6  Quit Easy Grade Pro and view the reports using your web browser. Find the folder you created, open it 

and double-click on any report page. If it doesn’t open, open your web browser, choose Open from the File 

menu, then navigate to the report and open it.
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Porting refers to the transfer of data to and from your gradebook. To import means to copy data from 

another file to your gradebook. To export means to create a new file that holds data from your gradebook. 

This chapter explains the many ways you can port data. 

Importing
Typically, importing is used to bring student names and other student record information into a grade-

book, but it can also be used to import options, scores and more. You can import from Easy Grade Pro 

gradebooks and text files. 

To import:
1  Select Import from the File menu or use the Import tool  IM   to open the Import window. The 

Import window has two tabs. Under the first, you’ll find the built-in formats. Under the second you’ll 

find user-defined and other editable formats. A format specifies the fields and structure of the data to be 

imported

2  (Optional) If the format that you need is not present, you can create one by first clicking the Other 

Formats tab and then clicking the New Format button. For help in creating a format, refer to the section 

Creating Formats for Importing and Exporting on page 113.
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3  Select a format, click Next.  The formats include:

•  Import from an EGP Gradebook. Use this format to copy students, options, assignments, a whole class, 

etc. from another Easy Grade Pro gradebook. The Import Gradebook window will appear where you can 

select the items to be imported.

•  “Easy Import” of Students. Use this format to import students from most tab-separated or comma sepa-

rated text files. Many database and spreadsheet programs use this format when creating text files. The Easy 

Import window will open where you can identify the fields in a record from the file. You must identify the 

first and last names but all other fields are optional. You must also name the format so that it can be added 

to the Import window where it can be reused directly.

•  “Easy Import” of Scores. Use this format to import scores from most tab-separated or comma separated 

text files. The records may be in any order as long as each contains a score and an ID number (or student 

name) to be used for matching. The Easy Import window will open where you must identify the score and 

the ID number (or student name) fields.

•  “Easy Import” of Standards. Use this format to import standards from most tab-separated or comma 

separated text files. The records may be in any order as long as each contains a standard ID and standard 

text. The Easy Import window will open where you must identify the these fields.

•  Import Summary Comments. Use this format to import a list of summary comments from a text file. 

The file must have comments only. This will replace the list in the Student Comments view of the Summa-

ries window.

•  Combine Gradebooks. Use this format to combine one or more gradebooks from other teachers into a 

single master gradebook to be used for the printing of multi-class progress reports or other reports. Note: 

there is a 250 class limit for a gradebook which means that you can typically combine up to ten grade-

books.

•  Other Formats. The formats that appear under the Other Formats tab can only be used to import stu-

dents and student record data from text files. There is a small blue arrow above the list of formats which 

allows you to duplicate a format or create a plug-in of a format. A plug-in is a small file that makes it easy 

to distribute a format to other Easy Grade Pro users. See Using Plug-ins on page 138 for additional infor-

mation.

4  For some formats, the Import Preview window will appear so that you can verify the data and select the 

records (students) to be imported. 
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Be sure to check that the data in the columns properly match the column titles. If they match, click the 

Import Selected Records button. If a selected student has the same ID number as a student currently in 

the class, the import data will be used to update the student’s record information. The student will not be 

duplicated in the class. This behavior allows you to import additional data, such as email addresses and 

passwords, later as long as the file as student ID numbers for matching.

FAQ: Can Easy Grade Pro import student rosters from my school’s school administration software and can 
it export grade data back to it?
In many cases the answer is ‘Yes’. If your school administration software can produce a roster file for a class in text 
format and if it can read a grade file for a class in text format, the standard version of Easy Grade Pro can probably 
share data with it. You, or someone at your school with the proper knowledge and expertise may have to create import 
and export formats within Easy Grade Pro. Plug-ins can be used to distribute the formats to other users. For help, see 
Creating Formats for Importing or Exporting on page 113 and Using Plug-ins on page 118. In some cases, custom 
versions of Easy Grade Pro are required. Contact Orbis Software for availability and pricing for custom versions.

Exporting
Exporting is typically used to transfer student grade data to a program used to print report cards, but it 

can also be used to transfer all kinds of student information to word processor, spreadsheet or database 

software to take advantage of the unique tools of these programs. When exporting, you can create two 

types of files: Easy Grade Pro gradebooks and text files. Text is a standard file format that many programs 

use for transferring data to other programs. 

To export:
1  Select Export from the File menu or use the Export tool  EX   to open the Export window. The Export 

window has two tabs. Under the first tab, you’ll find export formats that are built-in. Under the second tab 

you’ll find user-defined and other editable formats. A format is used to specify the fields of the data to be 

exported.

2  (Optional) If the format that you need is not present, you can create one by first clicking the Other 

Formats tab and then clicking the New Format button. For help in creating a format, refer to the section 

Creating Formats for Importing and Exporting on page 113.

3  Select the classes to be exported from the list on the left. Select  the students to be exported using the 

menu below the list. 
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4  Select a format and click Next.  What happens after clicking depends on the selected format. The formats 

include:

•  Export One Class. Use this format to create a new gradebook with a single class. This can be used to cre-

ate a file with data to be imported into another gradebook.

•  Export Gradebook Template. Use this format to create a new gradebook that has only the settings from 

the gradebook options, class options, comments windows. The template can be used by others when start-

ing their gradebooks.

•  Export Attendance. This format is usually not selected directly because it is automatically used whenever 

the Export Attendance tool is selected from the tool bar. For help, refer to the section Exporting Attendance 

on page 114.

•  Export Report Card Data. This format can be used to export student grade data to database software 

that prints custom report cards. This is explained in detail in the section Using the Report Card Data For-

mat on page 116.

•  Export Summary Comments. Use this format to create a text file of the list of comments found in the 

Summaries window. 

•  Export Standards List. Use this format to create a text file of the standards in a class.

•  Export XML Gradebook. This format allows you to export virtually all student data from one or more 

classes in an XML format. Although this data will not be usable by most off-the-shelf programs, district 

programmers or programmers at other software companies can write their own programs to take advan-

tage of this data for your benefit. For example, a program could be written to gather the student standard 

grades from the XML files created by multiple teachers for analysis of student performance on state stan-

dards. 

•  Other Formats. The formats that appear under the Other Formats tab can only be used to export stu-

dent data to text files. There is a small blue arrow above the list of formats which allows you to duplicate or 

create a plug-in of a format. A plug-in is a small file that makes it easy to distribute a format to other Easy 

Grade Pro users. See Using Plug-ins on page 118 for additional information.

5  If the Export Preview window appears, verify the data and click the Export button. 
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Creating Formats for Importing or Exporting
If you wish to import or export student data with spreadsheet, database, school administration and other 

software, you may need to create a porting format. This section explains how to create formats that appear 

under the Other Formats tab in the Import and Export windows.

Creating formats requires a certain amount of knowledge of file formats and ASCII codes. In addition, it 

requires 100% accuracy or else unpredictable results may occur. Proceed with caution!

By default, Easy Grade Pro separates fields (pieces of data) using tabs (ASCII 9) and separates records us-

ing a CR (carriage return, ASCII 13). Many word processing, spreadsheet and consumer database program 

also use this format when porting. In the PC world, many programs use a CR/LF (carriage return/line feed, 

ASCII 13/10) combination instead of a CR. You may need to modify a format to include a CR/LF. For help 

with this, see FAQ: How do I set the record delimiter to the CR/LF used by most Windows programs? on page 

114.

If you will be porting to or from school administration software, things can be much more difficult 

because these programs tend to use custom formats. For example, some files may use fixed-length fields 

(instead of variable length fields) that are left or right justified, with special fill characters and no delimit-

ers except at the end of a record. In many but not all cases, formats can be created in Easy Grade Pro to 

work with school administrative software.

To create a format:
1  From the Import or Export window, select the Other Formats tab. Then click the New button. The New 

Format window will open. On the left side of this window is a list of fields that are available for use in the 

format. 

2  To add a field to your format, select it in the list on the left and click the Copy button. The field is copied 

to the format list on the right. If a field is in the wrong position in the format list, press on it and drag it to 

the new location.  A format is limited to thirty fields per record.

3  (Optional) Select the Quotes button. Set this item if the data has (if importing) or should have (if 

exporting) quotation marks around each field. Under many circumstances, Easy Grade Pro will remove 

quotation marks automatically during importing.
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4  (Optional) To customize a field, select it and click the Edit button. Easy Grade Pro automatically uses 

a tab-delimited format in which each field is variable in length and is followed by a tab (ASCII 9) for 

most fields and a CR (ASCII 13) for the last field in a record. To change this formatting, or to make a field 

required (for export formats), select the field in the list on the right and click the Edit button. A small win-

dow will open with options for changing the format of a field. 

Only those with sufficient knowledge of file formats should attempt to make changes in this window. Any 

field that has been customized will have an asterisk appended to its name in the list.

If you set the Field Data Required item in an export format, Easy Grade Pro will block exporting until all 

required data are complete. 

5  Name the format in the text field at the top of the window and click Done. The name will appear under 

the Other Formats tab in the Import or Export window.

FAQ: How do I set the record delimiter to the CR/LF  used by most Windows programs?
By default, Easy Grade Pro adds a CR (ASCII 13) to the end of a record. If your format requires a CR/LF (ASCII 
13/10) combination, follow these steps: 
a)  Change the delimiter of the last field to CR (ASCII 13). To do this, select the last field and click the Edit button. In 
the window that opens, change the delimiter to CR.
b)  Add a Blank Field to the format. To do this, select Blank Field (the last field) in the list on the left and click the 
Copy button.
c)  Change the delimiter of the Blank Field to LF (ASCII 10). To do this, select the field and click the Edit button. In 
the window that opens, change the delimiter to LF.

Exporting Attendance
Easy Grade Pro allows you to export attendance over a network in just a few steps. 

To prepare for the exporting of attendance:
Careful preparations are required before exporting can begin. These are listed next.

•  Attendance Folder. A folder must be set up on a shared volume to hold the daily attendance export files. 

The pathname (name of folder, enclosing folders and volume) must not change once exporting has begun. 

The volume should be automatically mounted on each teacher’s computer. 

•  Attendance Categories. Each teacher’s gradebook must have the school’s attendance categories and 

codes. Although these can be set by each teacher using the Class Options window, it is suggested that a 

gradebook template be set up and made available to teachers.
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•  Export Attendance Format. Easy Grade Pro has a built-in export format for attendance. This format has 

the name Export Attendance and can be found under the Built-in Formats tab of the Export window. It has 

the following fields:

  Field 1 Selected Date 

  Field 2 ID

  Field 3 Last Name, First

  Field 4 Selected Day’s Attendance 

If desired, you can create your own custom format. See the section Creating Formats for Importing and 

Exporting on page 113 for help. In order for Easy Grade Pro to use your format, it must be named Export 

Attendance. It is best to include the format in a gradebook template.

•  Calendar Settings. Attendance data cannot be recorded until calendar options have been set in the Class 

Options window.

•  Export Attendance Tool. The Export Attendance tool  
EX
1   is used to start the export process. It must 

be placed on either the tool bar. To add the tool, press and hold on any occupied or unoccupied tool loca-

tion. Select the Export Attendance tool from the menu that appears. It is best to include this setting in the 

gradebook template.

•  Gradebook Template. A gradebook template can be used to ensure that all teachers’ gradebooks have 

the same settings. It also minimizes the work that teachers must do. First create a gradebook with the right 

settings. Then create a template of the gradebook. Refer to the section Exporting starting on page 111 for 

help. Teachers should create their gradebooks directly from the template. 

To export attendance:
Before you can export attendance, your gradebook must have the correct attendance categories and export 

format. The Export Attendance Tool must be on the tool bar and the volume to receive your attendance 

data must be mounted on your computer. You must know the name to use for your export file and the 

location in which it is to be saved. Be sure to enter your attendance data in the attendance chart or seating 

chart first. Then follow these steps:

1  Click the Export Attendance tool. A small calendar will appear (shown below). This calendar will auto-

matically display the current date but you may change this by clicking on another date. Click OK.
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2   Easy Grade Pro will gather the attendance data for the selected date and present it in the Export Preview 

window (shown below). This window is used to verify the attendance data. Note that only students with 

attendance marks appear. Even if the preview window is empty, it is important to export so that a file is 

created indicating that attendance has been sent. Click the Export Records button. 

3   If this is the first time that you are exporting attendance from the gradebook, the standard Save dialog 

window will open allowing you to name and save the export file. Use the unique name given to you. The 

location to save the file should be the attendance folder set up on a shared volume. Easy Grade Pro will 

remember the name and location and use them automatically in the future. 

If you saved the file using the wrong name or location, you must reset Easy Grade Pro. To do this, click the 

Export Records button in the Export Preview window while holding down the option (Macintosh) or Ctrl 

(Windows) key. You will be able to reset the name and location. 

Using the Report Card Data Format
This section explains the Report Card Data export format found in the Export window of Easy Grade Pro. 

This format can be used to export student data to a general-purpose database program so that custom 

report cards can be printed. 

The Report Card Data format consists of 157 fields (listed to the right). Virtually every piece of data about 

a student is included (other than individual attendance marks and assignment scores). Even the text found 

in the Summaries window is included. This format results in a tab-delimited text file. 

In most cases, this format cannot be used with the expensive, out-of-the-box school administration pro-

grams. Such programs have very specific data formatting requirements and lack the flexibility to handle 

the data in the 157 fields.

Rather, this format is to be used with general-purpose database programs, ones that offer rich sets of tools 

for importing, sorting, searching, data manipulation and form creation. These powerful programs are 

relatively inexpensive and are available for both Macintosh and Windows computers. However, using one 

of these programs to create a well-designed database requires much skill and time. This task is best left to 

experts. 

Once set up, it can be fast and easy to print your school’s report cards using data from files created using 

Easy Grade Pro’s Report Card Data format. 
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 1 Last Name, First
 2 Last Name
 3 First Name
 4 ID
 5 Gender
 6 Status
 7 Grade Scale
 8 Language
 9 Student Custom 1
 10 Student Custom 2
 11 Student Custom 3
 12 Student Custom 4
 13 Student Custom 5
 14 Student Custom 6
 15 Student Custom 7
 16 Student Custom 8
 17 Student Custom 9
 18 Student Custom 10
 19 Student Custom 11
 20 Student Custom 12
 21 Class Name
 22 Class Weight
 23 Class Custom 1
 24 Class Custom 2
 25 Class Custom 3
 26 Class Custom 4
 27 Class Custom 5
 28 Class Custom 6
 29 Class Custom 7
 30 Class Custom 8
 31 Overall Points
 32 Overall %
 33 Overall Grade
 34 Class Rank
 35 Class Average %
 36 Class Average Grade
 37 Current Term Points
 38 Current Term %
 39 Current Term Grade
 40 Category 1 Points
 41 Category 1 %
 42 Category 1 Grade
 43 Category 2 Points
 44 Category 2 %
 45 Category 2 Grade
 46 Category 3 Points
 47 Category 3 %
 48 Category 3 Grade
 49 Category 4 Points
 50 Category 4 %
 51 Category 4 Grade
 52 Category 5 Points
 53 Category 5 %

 54 Category 5 Grade
 55 Category 6 Points
 56 Category 6 %
 57 Category 6 Grade
 58 Category 7 Points
 59 Category 7 %
 60 Category 7 Grade
 61 Category 8 Points
 62 Category 8 %
 63 Category 8 Grade
 64 Category 9 Points
 65 Category 9 %
 66 Category 9 Grade
 67 Category 10 Points
 68 Category 10 %
 69 Category 10 Grade
 70 Category 11 Points
 71 Category 11 %
 72 Category 11 Grade
 73 Category 12 Points
 74 Category 12 %
 75 Category 12 Grade
 76 Category 13 Points
 77 Category 13 %
 78 Category 13 Grade
 79 Category 14 Points
 80 Category 14 %
 81 Category 14 Grade
 82 Category 15 Points
 83 Category 15 %
 84 Category 15 Grade
 85 #Missing Assignments
 86 Completed Work Points
 87 Completed Work %
 88 Completed Work Grade
 89 Term 1 Points
 90 Term 1 %
 91 Term 1 Grade
 92 Term 2 Points
 93 Term 2 %
 94 Term 2 Grade
 95 Term 3 Points
 96 Term 3 %
 97 Term 3 Grade
 98 Term 4 Points
 99 Term 4 %
 100 Term 4 Grade
 101 Term 5 Points
 102 Term 5 %
 103 Term 5 Grade
 104 Term 6 Points
 105 Term 6 %
 106 Term 6 Grade

 107 Term 7 Points
 108 Term 7 %
 109 Term 7 Grade
 110 Term 8 Points
 111 Term 8 %
 112 Term 8 Grade
 113 Term 9 Points
 114 Term 9 %
 115 Term 9 Grade
 116 Term 10 Points
 117 Term 10 %
 118 Term 10 Grade
 119 Master Attendance 1
 120 Master Attendance 2
 121 Master Attendance 3
 122 Master Attendance 4
 123 Master Attendance 5
 124 Master Attendance 6
 125 Master Attendance 7
 126 Master Attendance 8
 127 Master Attendance 9
 128 Master Attendance 10
 129 Attendance 1
 130 Attendance 2
 131 Attendance 3
 132 Attendance 4
 133 Attendance 5
 134 Attendance 6
 135 Attendance 7
 136 Attendance 8
 137 Attendance 9
 138 Attendance 10
 139 Attendance 11
 140 Attendance 12
 141 Attendance 13
 142 Attendance 14
 143 Attendance 15
 144 Today’s Date (short)
 145 Comment 1 (number)
 146 Comment 2 (number)
 147 Comment 3 (number)
 148 Comment 4 (number)
 149 Comment 5 (number)
 150 Comment 6 (number)
 151 Comment 1 (text)
 152 Comment 2 (text)
 153 Comment 3 (text)
 154 Comment 4 (text)
 155 Comment 5 (text)
 156 Comment 6 (text)
 157 Student Summary Note
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Using Plug-ins
Plug-ins are small files created using Easy Grade Pro that can be used to distribute import formats, export 

formats, standards lists and summary comments to other Easy Grade Pro users.

To create a plug-in of an import or export format:
Choose Import or Export from the File menu, click the Other Formats tab and select the desired format 

from the list. Press on the small blue arrow above the list and choose Save Item as Plug-in from the menu 

that appears. Then name and save the plug-in.

To create a plug-in of a set of standards:
Choose Records from the menu, click the Standards tab and press on the small button next to the Standard 

ID. Choose Save Standards as Plug-in. Then name and save the plug-in.

To create a plug-in of the list of comments in the Summaries window:
Choose Summaries from the Chart menu, click the Students tab on the left and the Comments (balloon) 

tab on the right. Press on the small blue arrow above the lower list and choose Save Comments as Plug-in 

from the menu that appears. Then name and save the plug-in.

To distribute a plug-in file:
Plug-in files should be placed in the same folder as the Easy Grade Pro application or should be placed 

in a folder titled Plug-ins found in the same folder as the Easy Grade Pro application. Whenever a person 

opens an Easy Grade Pro gradebook, Easy Grade Pro scans the plug-ins and transfers their contents to the 

gradebook. 

Be careful with plug-ins. A plug-in with comments will prevent the user from making lasting changes to 

comments in the Summary window. If the user makes changes to comments, the next time the gradebook 

is opened, the changes will be erased and replaced with what is found in the comments plug-in.

To remove a plug-in:
Drag the file out of the Plug-ins folder and out of the Easy Grade Pro folder. Note: this does not remove 

the contents of a plug-in from a gradebook if the contents have already been read into the gradebook.
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This chapter includes the most frequently asked technical questions about Easy Grade Pro and where to 

find the answers. If you can’t find your question in this section, at the end you’ll find email and phone 

information for contacting technical support at Orbis Software.

FAQs: Frequently Asked Questions
Chapter 1: Getting Started

Can Easy Grade Pro be networked? ( page 6)

Why am I getting an error message when I try to register Easy Grade Pro? (page 6)

What is the best way to learn the basics of Easy Grade  Pro in the shortest amount of time?  (page 8)

Chapter 3: Gradebooks and Classes
Easy Grade Pro saves automatically. What does this mean?  (page 20)

Chapter 4: Setting Options
What is grade-clicking? How does it work?  (page 24)

How do I set up my 5-point (or some other point) grading system? (Part 1)  (page 25)

How do I enter a check  mark as a special score?  (page 27)

How do I set up my 5-point (or some other point) grading system? (Part 2 )  (page 28)

I don’t remember the password. How do I get back in?  (page 34)

When I switch classes, my gradebook displays a message ‘Gradebook is locked --  changes could not be 

saved’. What is happening?  (page 34)

I have a group of students (or just one student) with unique assignments. How can I create a filter to show 

just this group and its assignments?  (page 36)

Chapter 5: Students and Assignments
How do I reshow a student once the status has been set to WD (hidden)? (page 42)

Why are the dates wrong on the calendars and in the charts? (page 43)

•

•

•

•

•

•

•

•

•

•

•

•

•
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What are maximum score and points? How should I set them?  (page 44)

If I use category weighting, does it matter how I set assignment points?  (page 44)

Why can’t I change the status on one of my assignments? It is stuck on Normal.  (page 45)

Chapter 6: Using the Score Chart
Why does the Find window keep popping up when I enter a score? (page 49)

How does Easy Grade Pro treat blank score cells? How can I easily set all blanks to a certain score?  (page 

49)

How is a student’s overall grade calculated?  (page 51)

Why wasn’t the lowest score dropped? Why are fewer scores being dropped for some students?  (page 53)

How can I keep my original scores on an assignment that I want to curve?  (page 55)

Chapter 7: Using the Standard Chart
How many standards should I add to my class?  (page 64)

What is the Power Law Formula for standards-based grading?  (page 66)

Chapter 9: Making and Managing Backups
My gradebook’s name is ‘Copy of copy of...’. What is going on?  (page 78)

Chapter 11: Working with Terms
I’ve combined terms but the prior-term grades or attendance data in reports are wrong. How do I fix this?  

(page 83)

I need to print reports that show grades from multiple terms but I don’t want the grades to be combined to 

form a multi-term overall grade.What do I do?  (page 84)

I have to include a weighted final exam. What do I do?  (page 84)

Chapter 12: Using Summaries
How can I check the calculations for one of my students?  (page 89)

Chapter 13: Printing Reports
Where is ePrint?  (page 92)

How can I maximize the columns on each page?  (page 93)

How do I print multiple reports per sheet of paper?  (page 93)

How do I change the teacher or school name that appears on reports?  (page 93)

How can I get a progress report to fit on a single sheet of paper?  (page 97)

Some assignments are not showing up in progress reports. How do I fix this?  (page 97)

Why are classes missing on a student’s multi-class progress report?  (page 97)

How do I remove the Overall column in a multi-class progress report?  (page 98)

How can I use the multi-class progress report as a report card for multiple teachers’ grades?  (page 98)

How do I show points in a progress report?  (page 98)

How can I use a progress report as a missing work report? ...as an attendance report?  (page 98)

What is the Completed Work Average and how is it calculated? (page 98)

Chapter 14: Emailing Student Reports
I’ve emailed reports successfully but some receivers explain that they can’t view them. How come?  (page 

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•
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102)

Chapter 15: Internet Reports
I’ve imported passwords. Why aren’t they showing up?  (page 104)

How can I ensure that I don’t compromise the privacy rights of my students?  (page 105)

Why don’t I see an index.html page in each folder?  (page 105)

Chapter 16: Porting
Can Easy Grade Pro import student rosters from my school’s school administration software and can it 

export grade data back to it?  (page 111)

How do I set the record delimiter to the CR/LF  used by most Windows programs?  (page 114)

Contacting Orbis Software for Technical Support
Orbis Software provides free technical support to registered users. Before you contact us, please be sure 

that you have read the FAQs above and you’ve searched this manual. Be sure to have the following in-

formation: your registration number, the version number of Easy Grade Pro (i.e. 4.0.0), your operating 

system (i.e. XP, Mac OS10.2.8) and a clear description of the problem. If calling for technical support, you 

are strongly encouraged to be at your computer.

   Address: P.O. BOX 73745, Puyallup, WA 98373

 Phone: (253) 848-6899 (Pacific Time)

 Fax: (253) 848-6505 (fax only

 Web: www.orbissoft.com or www.easygradepro.com

 Support: support@orbissoft.com

 Sales: sales@orbissoft.com

•

•

•

•

•
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Add Assignment
Opens the Records window to the first empty as-
signment record.

Add Furniture
Adds a piece of furniture to the seating chart.

Add Student
Opens the Records window to the first empty 
student record.

1
Auto-fill Attendance Scores
Replaces blank scores on selected assignments with 
special scores based on attendance marks.

?  ?
Change Scores
Changes all occurrences of a certain score to an-
other score.

Class Options
Opens a window where class options can be edited.

Copy Class Data
Copies selected students, assignments and options 
to other classes.

Curve Scores
Opens a window where the distribution of scores 
can be changed.

Delete
Deletes the selected scores, students, assignments, 
furniture, etc.

EX
1

Export Attendance
Exports one day’s attendance data to a text file over 
a network.

EX Export
Opens the Export window.

F
Fill Across
Repeats the selected data across a row to the last 
column.

F
Fill Down
Repeats the selected data down a column to the last 
row.

Find
Opens a window where search text can be entered.

Find Again
Finds the next matching student or assignment.

? Help
Opens the in-context Help window.

IM Import
Opens the Import window.

@
Internet
Opens a window where reports can be emailed or 
prepared for posting on the web.

Lock Gradebook
Locks the gradebook and opens the Lock window.

C Next Class
Switches to the next class in the current term.

T Next Term
Switches to the next term of the current class.

Print
Opens a window where reports can be printed.

C Prior Class
Switches to the prior class in the current term.

T Prior Term
Switches to the prior term for the current class.

RA Restricted Access
Turns the RA mode on and off.

Records
Opens a window with class, student, assignment 
and standard records.

Rotate Seat
Rotates the selected furniture 90° clockwise.

Save Copy
Makes a backup copy of the current gradebook.

Score Note
Opens a window where text can be entered about 
a score.

abc
Sort
Sorts students, assignments and seats based on the 
current chart.

Summaries
Opens a window with extensive summaries.

Undo
Reverses the last action.

Tools Reference
Up to twenty tools can be placed on the tool bar. To place a tool on the tool bar, press and hold on any 

unused tool or on an empty location. From the menu that pops up, select the desired tool.
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File Menu Reference
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View Menu Reference
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Chart Menu Reference
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